Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10. I think my problem in downloading some applications are related to this problem. I can't download applications using terminal. This is what I get:

A problem occurred when checking for the updates

I already tried these:

$ sudo aptitude update && sudo aptitude safe-upgrade
sudo: aptitude: command not found

$ sudo rm /var/cache/apt/*.bin 
no such file or directory

$ sudo apt-get update && sudo apt-get upgrade
E: type 'dev' is not known on the line 1 in the source list /etc/apt/sources/list.d/google.list
E: the list of sources could not be read

I was actually trying to download a postresql.

How do I resolve this?

share|improve this question

2 Answers 2

If you are using Ubuntu the command to update is...

sudo apt-get update

To install

sudo apt-get install postgresql

Also checkout your /etc/apt/sources.list file which might be corrupted it should look something like this so compare it to yours http://paste.ubuntu.com/5592482

If you need to edit the file you might need to type, especially if your path statements are corrupted

/usr/bin/sudo /usr/bin/vi /etc/apt/sources.list
share|improve this answer
    
I already tried that. Still error. I also tried -- sudo apt-get update == E: type 'dev' is not known on the line 1 in the source list /etc/apt/sources/list.d/google.list E: the list of sources could not be read –  MichNonato Mar 7 '13 at 6:51
    
I always get this response "E: type 'dev' is not known on the line 1 in the source list /etc/apt/sources/list.d/google.list E: the list of sources could not be read" Please help –  MichNonato Mar 7 '13 at 6:55
    
What will am i going to do with the paste.ubuntu.com/5592465 ? thanks –  MichNonato Mar 7 '13 at 7:14
    
thanks. Well, i only found this called google.list in /etc/apt/sources.list. And inside the google.list "dev dl.google.com/linux/chrome/deb stable main" –  MichNonato Mar 7 '13 at 7:21
    
oh sorry, yeah my mistake. I found a lot of differences from what you gave me (paste.ubuntu.com/5592465)and my source.list. –  MichNonato Mar 7 '13 at 7:30

There might be a problem with your Google Chrome installation. Try uninstalling it with

sudo apt-get --purge remove google-chrome google-chrome-stable

After that, run

sudo apt-get install -f

Then update with sudo apt-get update

I find the best way to install chrome is just to go here https://www.google.com/intl/en/chrome/browser/ and download the .deb file.


In regards to the error you are getting, try opening the troubled file with this command:

sudo gedit /etc/apt/sources/list.d/google.list

Change the word "dev" to "deb". It's a typo. Save this. And close GEdit. Then run sudo apt-get update.

You are getting aptitude: command not found since aptitude is a program that must be installed first with sudo apt-get install aptitude

share|improve this answer
    
i tried the ones you recommend still im getting this response "E: type 'dev' is not known on the line 1 in the source list /etc/apt/sources/list.d/google.list E: the list of sources could not be read". My software center doesn't work either. Keeps force closing. I tried to fix it same response. –  MichNonato Mar 7 '13 at 7:10
    
yeah, its my mistake. I Used terminal to install chrome –  MichNonato Mar 7 '13 at 7:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.