Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm hoping someone here could help me with the installation problem I'm having, namely Ubuntu doesn't detect my hard drives. I've tried installing from a disc and using wubi; neither have worked. Drives are detected just fine in Windows 7.

I searched around to see if any of my hardware is incompatible, but didn't find anything. Here's a list just in case I missed something:

  • Mobo: ASRock H61M/U3S3 LGA 1155 Intel H61 SATA

  • RAM:G.Skill Sniper 8GB(2 X 4) 240 pin DDR3

  • GPU: GeForce GTX 560 Ti

  • CPU: Intel i5-2400 3.1 GHz Quad-core

  • HDD: Western Digital WD Blue WD50000AAKX 500GB SATA

  • SSD:Intel SSDSC2CW120A 128GB

Nothing shows up in gparted or disk utility when I run the live CD.

I ran the boot info script, the results of which are:

Boot Info Script 0.61 [1 April 2012]

============================= Boot Info Summary: ===============================

============================ Drive/Partition Info: =============================

no valid partition table found
"blkid" output: __________________________________________________ ______________


/dev/loop0 squashfs
/dev/sr0 iso9660 Ubuntu 12.10 amd64

================================ Mount points: =================================

Device Mount_Point Type Options

/dev/loop0 /rofs squashfs (ro,noatime)
/dev/sr0 /cdrom iso9660 (ro,noatime)

========= Devices which don't seem to have a corresponding hard drive: =========

no block devices found

=============================== StdErr Messages: ===============================

No volume groups found 

Does anyone have any ideas as to what the problem could be? No one over at ubuntuforums had any ideas.


share|improve this question

Have you made sure you've mounted your memory devices? Ubuntu does not automatically mount storage mediums by default, so if you haven't done that yet try checking here and here. Also try this similar looking question depending on whether you're talking about external hard drives. Just from personal experience, I can say that Ubuntu is very good at controlling devices/files (since everything is a file) and if there's one thing that it does correctly, that is it.

share|improve this answer
They're internal hard drives. From what I gathered from the links, mounting is done in windows by formatting and assigning them a drive label, right? If so, then yes they are mounted, if not, apparently I'm confused as to what mounted means. – Erebus04 Mar 7 '13 at 2:02
I suppose you could call that the windows equivalent. But windows does that automatically, while Ubuntu does not, so if you have trouble locating the drives in Ubuntu, try mounting them (see links in above answer). – data88 Mar 7 '13 at 4:49
Hmm... I tried some of the advice in the thread. I couldn't use mountmanager because when I try to install from the terminal, it ends with "E: Unable to locate package mountmanager". I wasn't exactly sure how to edit the fstab since I didn't know what to mount. I tried to get some ID to use in mounting with 'blkid', but the only thing that shows up is the C.D. – Erebus04 Mar 7 '13 at 21:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.