Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed the Inifinity style to Conky on my Ubuntu 12.04 system using XFCE4 as my WM and Desktop.

http://www.unixmen.com/infinity-a-stunning-theme-for-conky-ubuntu-linuxmint-fedora/

It works fine, problem is that my desktop icons won't display.

My .conkyrc file is here:

#########################################################################################
#    Conky Theme : Infinity                                                                                                                                                                                          #
#    Created by     : Harshit Yadav                                                                                                                                                                              #
#    Version           : 1.0                                                                                                                                                                                                  # 
#    Feel Free to distribute                                                                                                                                                                                         #
#    For Installation Instrcutions See Read Me                                                                                                                                                       #
########################################################################################


# Conky settings #
background yes
update_interval 1

cpu_avg_samples 2
net_avg_samples 2

override_utf8_locale yes

double_buffer yes
no_buffers yes

text_buffer_size 2048
#imlib_cache_size 0

temperature_unit fahrenheit

# Window specifications #

own_window yes
own_window_type override
own_window_class Conky
own_window_transparent yes
own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below

border_inner_margin 0
border_outer_margin 0

## This Resolution is set according to the sreen resolution of 1366x768 
## Adjust Accoring to yours

minimum_size 1024 768
maximum_width 1024

alignment tr
gap_x 10
gap_y 55

# Graphics settings #
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no

# Text settings #
use_xft yes
xftfont caviar dreams:size=8
xftalpha 0.5

uppercase no

temperature_unit celsius


default_color FFFFFF

# Lua Load  #
lua_load ~/.lua/scripts/haunted.lua
lua_draw_hook_pre clock_rings

## Adjust these fields according to the your screen size i have modded them for 1366X768

TEXT
${offset 600}${color EAEAEA}${font GE Inspira:pixelsize=80}${time %l:%M %p}
${offset 650}${font}${voffset -84}${voffset 10}${color FFA300}${font GE Inspira:pixelsize=42}${time %d} ${voffset -15}${color EAEAEA}${font GE Inspira:pixelsize=22}${time  %B} ${time %Y}${font}${voffset 70}${font GE Inspira:pixelsize=58}${offset -550}${time %A}${font}
${offset 650}${voffset -100}${font Ubuntu:pixelsize=10}${color FFA300}HD ${offset 9}$color${fs_free /} / ${fs_size /}${offset 30}${color FFA300}RAM ${offset 9}$color$mem / $memmax${offset 30}${color FFA300}CPU ${offset 9}$color${cpu cpu0}%
${voffset 10}${offset 270}${color 2c2c2c}${hr 4}
${image ~/.conky/rev-eng.png}


${offset 130}${voffset 222}${font Santana:size=9:style=Bold}root : ${font Santana:size=9}${fs_used /}/${fs_size /}
${offset 130}${voffset 10}${font Santana:size=9:style=Bold}home: ${font Santana:size=9}${fs_used /home}/${fs_size /home}$font
${offset 120}${voffset 12}${color ffffff}${font Santana:size=9:style=Bold}swap: ${font Santana:size=8} ${swap} / ${swapfree}$font
${offset 570}${voffset -110} ${color EAEAEA}Linux ${kernel} kernel
${offset 570}${voffset 5} Uptime :${uptime}
${offset 825}${voffset -80}${color ffffff}${font Santana:size=10:style=Bold}${exec whoami}@${nodename}
${offset 825}${voffset 0}${color ffffff}${font Santana:size=8}${top name 5} ${top mem 5}
${offset 700}${voffset 130}${color ffffff}${font Santana:size=8}IP Address :${addr eth0}
${offset 705}${voffset 10}${color ffffff}${font Santana:size=8}Down :${downspeed eth0} k/s ${offset 8}Up:${upspeed eth0} k/s
${offset 703}${voffset 10}${color ffffff}${font Santana:size=8}TCP Connections: ${tcp_portmon 1 65535 count}

A lot of places on the NET have suggested changing settings on the own_window_type override part, I have tried all 3 of them; normal, desktop and override

desktop and normal only display a black background and totally mask my desktop. While as override will at least display my wallpaper.

If I right click on it anywhere it pops up my right click menu for the desktop. So it's getting there but no icons.

http://i.imgur.com/stthsQP.png
http://i.imgur.com/Zr9WBmp.png

Also if I right click on where an icon should be it display the popup menu for that file, so it works just doesn't display.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Seems this problem is caused by XFWM and Compositor. This can be fixed by enabling compositor for XFWM:

Settings -> Settings Manager -> Window Manager Tweaks -> Compositor -> Enable Display Compositing

Default settings enabled and just enable it. Then change your config for conky to this:

own_window yes
own_window_type desktop
own_window_transparent yes
own_window_argb_visual yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

It's now working 100% for me in XFCE.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.