Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new problem that I can't find an answer to anywhere. I am running Xubuntu 12.10 Xfce. When I click on the top left icon, which is known as the Application menu, it gives me this error:

Failed to load the applications menu : Error on line 1 char 1: Document was empty or contained only whitespace.

Can someone please suggest any solutions for this problem.

share|improve this question

Removing and reading didn't help me, but after reading (but not trying) user63872's answer, I just deleted this one file:


and suddenly it worked again.

share|improve this answer

That didn't work for me but copying the contents of /etc/xdg/menus/ over the contents of HOME/.config/menus/ as a merge/replace did, this reset the menu to a default layout and got it working again. I think the main menu editor may not have worked correctly for me and caused this error, but that's just a guess. There is probably a more specific way to fix but I don't know myself.

share|improve this answer
Welcome to Ask Ubuntu! This seems to be an answer and not just a comment on another answer, but which answer are you saying didn't work? Please note that Ask Ubuntu works very differently from a forum; there's no persistent order that answers appear. – Eliah Kagan Apr 10 '13 at 9:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.