Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.10 installed on my desktop PC and my Acer Notebook. I have tried connecting my Android Device - Xperia Mini Pro (SK17i) on my Acer Notebook and it is working well. Mass Storage Mode was working well and even the USB Tethering is working well too.

But when I tried to connect it to my desktop PC it's not detected. So what should I do?

I have Android 2.3 on my Xperia Mini Pro (SK17i). And here is what i get from dmesg

[ 1495.212008] usb 2-10: >new full-speed USB device number 27 using ohci_hcd

[ 1495.239209] usb 2-10: >not running at top speed; connect to a high speed hub

[ 1495.257210] usb 2-10: >Dual-Role OTG device on non-HNP port

[ 1495.260210] usb 2-10: >can't set HNP mode: -32

share|improve this question
Have you tried all of the USB ports on your desktop PC? Incase you had Windows on it previously, did it work then? –  pileofrocks Mar 6 '13 at 19:47
some port make USB Debugging show up but it's still not working –  Ariona Rian Mar 6 '13 at 20:12
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.