Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had enabled "hibernate" option in my Ubuntu 12.10 few months back by adding the following lines to /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

However, I don't know how, rather don't remember what led to it being disabled both in "power options" and in the "gear icon" on the menu bar.

The file is still intact.

One of the things I suspect is removing old kernels using Ubuntu tweak, but have no valid reason to allege this :P

share|improve this question
    
try this How to Enable Hibernation in Ubuntu –  user268084 Apr 12 at 5:44
    
I had to create that policy file in /var/lib instead of /etc (Ubuntu 14.04). After killall unity-panel-service it immediately appeared under the gear menu. –  Vincent Jul 22 at 10:51

2 Answers 2

up vote 3 down vote accepted

Ghosh... how did I take so long in discovering that I didn't have an entry for the swap partition in my /etc/fstab file?

The problem was, I had deleted my swap partition and then re-created it some days later, but did not realize that /etc/fstab had the old entry and the newer one was never added to it.

Adding the entry and rebooting my laptop now gives me the option to hibernate.

share|improve this answer

Try running sudo update-grub, occasionally this is necessary if you change grub settings or configurations. From the highest searched answer to this question: (How to enable hibernation?) "Some users will then need to run sudo update-grub to get the hibernate option to be available in the power menu.."

share|improve this answer
    
Thanks @handuel, but there is no change. –  i08in Mar 6 '13 at 17:07
    
@Jobin Well, there would be no change. grub is the bootloader for Ubuntu (To Dual-Boot), so no change would happen. –  nerof61 Mar 6 '13 at 17:13
    
@nerof61 I quote: "Some users will then need to run sudo update-grub to get the hibernate option to be available in the power menu.." –  handuel Mar 6 '13 at 20:32
    
Hmm... true...! –  nerof61 Mar 8 '13 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.