Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to ubuntu so please forgive my ignorance.

I recently bought an alienware M14x R2 with a '1GB GDDR5 NVIDIA® GeForce® GT 650M' vide card. I followed this tutorial to installed Ubuntu 12.10 on Virtualbox 4.2.8 but am experiencing serious screen/graphics lag. The host sytem is windows 7 & I have a intel i7-3630QM processor.

So far I've tried:

  1. Installing VirtualBox Guest Additions from the VB device menu, the installtion completed succesfully but did not resolve the screen lag issue.
  2. I installed bumblebee as descibed in their wiki. It seemed to install correctly but after reboot did nothing. The terminal commands where:

    sudo add-apt-repository ppa:bumblebee/stable

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

    sudo apt-get update

  3. Then I tried to install the guest additions on the ubuntu CLI as described here:

    • upubuntu.com/2012/08/how-to-install-virtualbox-guest.html.
    • Again this installed correctly but did nothing after reboot.
    • The terminal commands where:

      sudo apt-get install virtualbox-guest-additions

      sudo apt-get install virtualbox-guest-dkms virtualbox-guest-x11 virtualbox-guest-utils

  4. Then in desporation I enabled 3d acceleration in the Virtualbox display settings, but this seemed to do nothing.
  5. Finally in a last ditch effort I enabled IO APIC in the virtual box system setting & increased the number of processors to 4 CPUs.
    • This improved the screen lag a fair bit but not entirely & I still can't switch to seamless mode.
    • I'm not really sure if it's the correct resolution as I don't know if I have hardware virtulization which I've read is required for this.

Is this the correct solution or should I try something else, perhaps I need to remove some of the repositories added & start over but I'm unsure how to do this?

Any help/advice would be much appreciated, I'd be happy to add more detail if needed.

Thanks

share|improve this question
    
This is probably either a bug in VirtualBox, a bug in Ubuntu's handling of being in VirtualBox, or both. You need to try running Ubuntu "on the metal" before coming to us with your problem. –  InkBlend Mar 6 '13 at 16:19

1 Answer 1

up vote 0 down vote accepted

Bumblebee was only designed to work when you install Ubuntu on your actual hardware, not in a virtual machine.

Virtual box emulates the hardware that the guest OS is running on. The guest OS doesn't see your actual hardware, it sees the emulated hardware. You need to remove that and install VirtualBox guest edition.

To remove bumblebee (though it is not affecting your system now)

sudo apt-get install ppa-purge
sudo ppa-purge ppa:bumblebee/stable

Go to the link and download the ISO file. Mount it as described here - http://www.virtualbox.org/manual/ch04.html#mountingadditionsiso (Follow instruction for windows host)

Then, follow - http://www.virtualbox.org/manual/ch04.html#idp19235216

In short, these instruction has three part, in linux guest

sudo apt-get install dkms

Then, in terminal, navigate to mounted ISO, like cd /media/<VBOX_ISO_NAME> (use tab to see the available options)

Then run, sudo sh ./VBoxLinuxAdditions.run

share|improve this answer
    
thank you, what comand should I put into the terminal to remove bumblebee? –  Creed Bratton Mar 6 '13 at 16:42
    
Did you mean install virtualbox guest edition or virtualbox guest additions? I already have VirtualBox 4.2.8 for Windows hosts x86/amd64 installed, I could not find a guest edition on that link. –  Creed Bratton Mar 6 '13 at 16:44
    
updated with few details. –  Web-E Mar 6 '13 at 17:23
    
Thanks this helped a great deal but got an error message: The headers for the current running kernel were not found. But by running sudo apt-get install linux-headers-$(uname -r) it fixed this error & your solution worked for me after another attempt. Thank for your help, now I can use uBuntu on my new laptop :) –  Creed Bratton Mar 7 '13 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.