Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had to reinstall my Windows 7 due to some problems, before that I was running a dual boot with Ubuntu 12.04, which was originally installed from Windows (via Wubi) in a separate partition.

After reinstalling Windows the screen where I could choose the OS to boot to was gone, I searched for a solution and installed EasyBCD, from there installed Neogrub, added an entry for Ubuntu (tried type GRUB2 and GRUB Legacy, nothing changed). Now I get to Windows boot manager after rebooting, but if I choose Ubuntu it says 'Windows was not installed correctly', so clearly something is wrong. This is the boot menu:

There are a total of 3 entries listed in the bootloader.

Default: Windows 7
Timeout: 15 seconds
Boot Drive: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: NeoGrub Bootloader
BCD ID: {8355e9dd-8693-11e2-94ba-98e0820b23a5}
Drive: C:\
Bootloader Path: \NST\NeoGrub.mbr

Entry #3
Name: Ubuntu
BCD ID: {8355e9df-8693-11e2-94ba-98e0820b23a5}
Drive: E:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

I`m no expert, but the Bootloader Path for Entry #3 looks wrong, however I don't know how to change it (or what should I change it to).

Now I realised I should have installed Ubuntu from a Live CD not wubi, but it's too late for that. I'm thinking there has to be some way to acces Ubuntu, cause it`s all there in its partition.

edit: I tried running wubi to refresh my memory, now I remember what I did, I changed the 'Installation drive' from C to E, which is a partition I created just for Ubuntu and which is still there, unformatted.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

To answer my own question (in case anybody else has this problem, it is possible to fix this. Using EasyBCD is just the first step, after creating an entry for Ubuntu (be sure to set the Type to wubi, not GRUB) you have to tell Windows where to boot Ubuntu from. To do this, open a command prompt with administrator rights, and run

bcdedit and look at the end of the output under 'Real-Mode Boot Sector' at the identifier.

Then run bcdedit /set {device_id} partition=X:

where device_id is the ID from above and X is the partition where you installed Ubuntu.

Lastly, run

bcedit /set {device_id} path \your_ubuntu_path\winboot\wubildr.mbr

Again, replace device_id and 'your_ubuntu_path' with the path to the wubildr.mbr file (probably it`s in \ubuntu\winboot\ on the partition where you installed Ubuntu)

That`s it, the dual-boot should work correctly again (at least for me it did).

share|improve this answer
    
If this has fixed your problem, can youu please mark it as the correct answer? –  Dan Mar 6 '13 at 23:22
    
Sorry but I cant...its possible I already had an account before posting this question, and now I have two... –  Mihnea Mar 7 '13 at 8:38

Something is not right in you description or I cannot understand it.

You said

"before that I was running a dual boot with Ubuntu 12.04, which was originally installed from Windows (via Wubi) in a separate partition."

and this cannot be happened. When use the wubi.exe installer , Ubuntu will be installed inside Windows. So no separate partitions exits .. etc.

If you are absolutely sure that you have installed Ubuntu via wubi.exe , then with the re-installation of Windows, Ubuntu was just gone. Via wubi.exe Ubuntu is nothing more but a program installed inside Windows. You can find it from Windows control panel and remove it like any other simple Windows program.

If you are unsure about the type of Ubuntu installation you followed , then I would suggest to use boot-repair and see if your boot problem solved and/or provide here the boot-info log.

share|improve this answer
    
I dont remember exactly what I did, but I definitely used wubi. I created a new partition for Ubuntu, but maybe it was just a storage space for files in Ubuntu or something. In this partition, this is what I can see (from windows): a folder 'ubuntu' (inside it 3 folders: disks, install, winboot) and a file called wubildr. So maybe wubi is not gone since this isnt the primary partition that was formatted by reinstalling Windows, maybe it's not linked with Windows anymore? –  Mihnea Mar 6 '13 at 16:10

As Windows was installed with Wubi, Ubuntu would of been in the directory of Wubi. Now that you re-installed Windows 7, Wubi is deleted. So I am afraid Ubuntu is long gone.

I would imagine if you clicked 'Upgrade' from the Windows 7 installation I would presume it created a System Restore Point. If you type in to the Start Menu 'System Restore' I guess you could have a go at recovering Wubi. But it is probably gone.

Hope this helps!

share|improve this answer
    
As you guessed, the system restore didn't help...thanks anyway! –  Mihnea Mar 6 '13 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.