Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using GNOME-Classic and my window switcher is the Compiz Static Application Switcher. My problem is, when I press Alt+Tab, the switcher gives me the choice between windows of the whole workspace.

So if I have one terminal opened in the first screen, and one terminal open in the second one, I can't know which one is selected and open the bad one 50% of the time. On my older ubuntu version (10.10), I hadn't such a problem, so I think there may be a solution to avoid it.

I found in this post that this is not possible to have one workspace/screen, so there's probably something I miss somewhere else.

Edit (summary): when I do Alt+Tab in one screen, I want to only see the windows I have in that screen, not the other one.

share|improve this question
    
You have multiple screen or workspace setup? –  BigSack Dec 4 '13 at 15:45
    
edited my answer to add your I want to only see the windows I have in that screen, not the other one. requirement. –  Arno van der Weijden Dec 4 '13 at 16:41
add comment

1 Answer

up vote 7 down vote accepted
+50

You can change the behavior of Alt + Tab with an option in compizconfig-settings-manager that lets you group the applications together from the active viewport.

To install CCSM, run the following command in a terminal:

sudo apt-get install compizconfig-settings-manager

To enable the setting click on Ubuntu Unity plugin and select Switcher tab and tick Bias alt-tab sorting to prefer windows on the current viewport.

Ubuntu Unity plugin

the option you should select

This will ensure that the applications from the same viewport will get grouped together in the window switcher. However this will not remove everything that isn't on your viewport. It just groups them together making it easier to keep them apart.


If you want to completely remove the other windows from your not active viewport from your alt tab menu you'll need to a different switcher like the static application switcher. You can activate the static switcher by doing the following:

start CCSM

click the Ubuntu Unity Plugin and go to the switcher tab. In this tab you'll need to disable the hotkey to start the switcher, the hotkey to flip through the windows in the switcher and the one to switch through the windows backwards.

Enable the Static Application Switcher by checking Window Management ▸ Static Application Switcher ▸ Enable Static Application Switcher

static application switcher

You should only switch between windows on your active viewport like you did on your old install.

If you do not get the static application switcher option you can try running the following command:

sudo apt-get install compiz-plugins-extra

I do have a little warning though: What are some of the issues with ccsm and why would I want to avoid it?

If this didn't work you can comment and I'll post another method.

share|improve this answer
    
Thank you, anyway I am no more able to test it as I'm back on macs (don't troll pls :p), I mark your answer ; at least it may be useful to somebody else :) –  Ninsuo Dec 5 '13 at 8:27
    
very well, to each his own –  Arno van der Weijden Dec 5 '13 at 15:05
2  
+1. You deserve another +1 for the link about the dangers of compiz to the careless, but sadly I can only give you 1. and @Ninsuo, at least if it's not Ubuntu, it's not Windoze either.. :p –  TrailRider Dec 9 '13 at 22:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.