Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the 64-bit Ubuntu 12.04 on my HP Pavilion laptop, but the touchpad isn't working. I've already tried reinstalling, so that won't fix it.

I've managed to get the terminal open using Ctrl+Alt+T, but I don't know what I'm doing. So can someone help me with this?

share|improve this question

4 Answers 4

You could try this command in terminal (found in http://ubuntuforums.org/showthread.php?t=1971196 this thread)

sudo apt-get install xserver-xorg-input-synaptics

Does your laptop by any chance have a built in keystroke (button press, combination of buttons to press etc) to enable/disable the touchpad?

share|improve this answer
    
Just tried that and it didn't work. It claims it's already the newest one. It doesn't have any keystrokes that can disable the touchpad. I've found external mouses aren't working either though –  user128117 Mar 6 '13 at 5:06
    
same problem for me with my old dell inspiron 6000 (even if correctly enabled) :/ what returns xinput in the terminal ? also, have a look at systems settings > mouse and touchpad to see if it is correctly enabled –  riimzzai Mar 6 '13 at 23:04

Try Fn and "F" keys - just don't hit any you know do something you don't want (like turn off your wireless). Someone else was trying to hook my laptop up to a TV, and accidentally hit Fn + F9. The Mousepad control still showed it as enabled; restarting, disabling then enabling - nothing worked until I hit the right hotkeys.

share|improve this answer

The following steps in the article solved my problem like a charm:

Is Your Laptop Touchpad Not Working After Upgrading To Ubuntu 11.10? Try to Enable it with Dconf-Tools


Open the terminal and install dconf-tools with this command:

sudo apt-get install dconf-tools

Via the Unity Dash, launch dconf Editor

Navigate now to this path:

org > gnome > settings-daemon > peripherals > touchpad

On the right pane of the window, check on touchpad-enabled to enable it.

After you finish close the editor, no reboot or logoff is required.

share|improve this answer

I have had success with HP Laptops in the past using the reset procedure described in this article: HP Pavilion TouchPad not working

What model of laptop are you using? Are you sure you have a Synaptics Touchpad?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.