Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I was trying to install the proprietary nvidia drivers for my optimus laptop. This resulted in my GUI disappearing, I can only see my desktop background (can still open terminal and right-click the desktop to get into options). I have followed lots of tutorials that don't result in any change. How can I switch back to the Nouveau drivers that are already installed? I have an nvidia 660m with optimus

share|improve this question

marked as duplicate by Takkat, hhlp, AgentCool, LnxSlck, Eric Carvalho Mar 7 '13 at 0:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

One of the following should work:

sudo apt-get remove --purge nvidia-current
sudo apt-get remove --purge nvidia-current-updates

Follow that with an

sudo apt-get autoremove

Plus, you may want to start afresh on your X configuration

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

If you are still having problems, could you please clarify which instructions you followed to install the nvidia drivers and what you tried so-far to remove them.

share|improve this answer
    
That didn't work. Neither nvidia-current nor nvidia-current-updates is installed, and apt-get autoremove found no packages to remove. sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup failed with "mv: cannot stat ‘/etc/X11/xorg.conf’: No such file or directory" as the error. I was installing bumblebee 3.1. The first set of directions was "sudo add-apt-repository ppa:bumblebee/stable sudo apt-get update sudo apt-get install bumblebee bumblebee-nvidia", which didn't break anything but also did not get the graphics card working. It then had me remove my nvidia drivers, which broke the GUI –  EvilBlob Mar 6 '13 at 3:49
    
The webpage with these instructions seems to have been removed, possibly do to this problem –  EvilBlob Mar 6 '13 at 3:51
    
Ok, I found the solution to my problem. After going through all the driver changes that I did, the unity plugin became disabled in Compiz. To fix this, open a terminal, type ccsm to open Compiz, then enable the 'Ubuntu Unity Plugin' and disable all the conflicts and reboot. That seems to have fixed my problems. –  EvilBlob Mar 6 '13 at 4:11
    
Sounds good. You can add that as an answer (it's possible to answer your own question and get reputation for it) if you like. –  neon_overload Mar 6 '13 at 13:38
up vote 2 down vote accepted

Ok, I found the solution to my problem. After going through all the driver changes that I did, the unity plugin became disabled in Compiz. To fix this, open a terminal, type ccsm to open Compiz, then enable the 'Ubuntu Unity Plugin' and disable all the conflicts and reboot. That seems to have fixed my problems. Turns out it was only loosely a driver problem after all.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.