Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm interested in the IOGear Universal Wi-Fi N Adapter as a wifi adapter. The fine manual states:

Installation without WPS - Mac 
Step 1: Turn off your computer’s wireless connection (if applicable) and disconnect the Ethernet cable currently connect to your computer (if applicable). 
Step 2: Use both the included RJ-45 Ethernet cable and the USB cable to connect the
WiFi adapter with your computer. 
Step 3: Set your computer with a static IP address. a. Open system preferences and select “Network”. 
b. Select your Ethernet connection in the left pane. Next change configure to Manual and enter IP address 192.168.1.100 and Subnet Mask 255.255.255.0. Remove any entries in the Router and DNS boxes then click Apply. 
Step 4: Open your web browser and enter 192.168.1.252.
This will bring up the configuration utility. Click “Site Survey” to
scan for your wireless network.

I'm using XFCE and would like to set the IP address as above with the GUI:

network connections

However, how do I know that the above setting is being utilized? The ifconfig utility reports an IPv6 type address and no IPv4 information. I'm a bit stuck between the GUI showing data and that the CLI seems to give a different result. How is the GUI connected to ifconfig results? It seems odd that ifconfig results do not match GUI settings.

(It's somewhat difficult to provide data as the computer this is happening on does not have internet access.)

I do not have many "standard" Ubuntu options, only bare XFCE.

After typing in ifconfig eth0 down and then ifconfig eth0 up the result is an IPv6 type address.

share|improve this question
    
Edit your question and mention that you have used ifconfig eth0 down and ifconfig eth0 up. –  Mostafa Shahverdy Mar 6 '13 at 1:52

1 Answer 1

up vote 1 down vote accepted

My router settings as so:

Router Status
Hardware Version    WNR1000v2
Firmware Version    V1.0.1.1NA
GUI Language Version    V1.0.0.35
Internet Port
MAC Address     C0:3F:0E:8B:4D:05
IP Address  192.168.0.16
Internet    DHCP
IP Subnet Mask  255.255.255.0
Domain Name Server  64.59.144.18
64.59.150.134
LAN Port
MAC Address     C0:3F:0E:8B:4D:04
IP Address  192.168.1.1
DHCP    ON
IP Subnet Mask  255.255.255.0
Wireless Port
Name (SSID)     NETGEAR
Region  United States
Channel     Auto ( 2(P)+6(S) )
Mode    Up to 150 Mbps
Wireless AP     ON
Broadcast Name  ON
Wi-Fi Protected Setup   Not Configured

with the IOGear Universal Wi-Fi N Adapter connected to the yellow "internet" port on the router. Now, it was a bit tricky configuring the IOGear device and I don't have the details, but in general it was as so:

Access Point Status
This page shows the current status and some basic settings of the device.

System
Uptime  0day:0h:22m:34s
Firmware Version    AC1x1-1201-B03
Build Time  Thu Jun 23 17:42:14 CST 2011
Wireless Configuration  
Mode        Infrastructure Client   
Band        2.4 GHz (B+G+N)
SSID    

425BF3

Channel Number      11  
Encryption      WPA2
BSSID   70:54:d2:36:b7:05
Status  Connected
Wireless Configuration  
Mode        Infrastructure Client   
Band        2.4 GHz (B+G+N)
SSID    

425BF3

Channel Number      11  
Encryption      WPA2
BSSID   70:54:d2:36:b7:05
Status  Connected
TCP/IP Configuration
Attain IP Protocol  Fixed IP
IP Address  192.168.1.252
Subnet Mask     255.255.255.0
Default Gateway     0.0.0.0
DHCP Server     Disabled
MAC Address     00:21:79:c6:5a:de

Which is quite odd because the Default Gateway is 0.0.0.0, which makes no sense. I even tried setting the gateway as so:

thufir@dur:~$ 
thufir@dur:~$ cat /etc/network/interfaces.static 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.252

# The secondary network interface
auto eth1
iface eth1 inet dhcp
thufir@dur:~$ 

as /etc/network/interfaces but even after doing so, and running service network stop and then start, just couldn't get the default gateway to a non-zero address.

Magically, or seemingly so, just moving some ethernet cables around for some double-NAT action, now the IOGear supplies the internet connection for the router, which the computer connects to.

Strange. I welcome comments, suggestion and alternate solutions.

Hmm, seems that the router is automagically configuring itself for a static IP address -- although that address might change when the IOgear device is booted (I'm not sure about that):

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.