Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's been two days I have tried to make this work. I have 3 sound output : regular audio jack from my soundcard, USB MOTU soundcard, USB Logitech speakers. The latter two seem not to be detected at all. The first seems to be detected but still no sound. I have uninstalled and reinstalled PulseAudio and AlsaMixer according to some tip on a blog but it did not work either. All the above work like a charm on Windows 7 and Windows 8.

I'm really trying to give Ubuntu a try but it's starting not to be such a great experience when I can't get something this simple to work after two days :|

And yes I have double (triple) checked that the volume on all devices is not turned off and that no mute setting is on (including auto-mute in alsamixer).

Does anyone have a clue what could be wrong ?

Thanks

(Also, please assume I have no knowledge at all of Ubuntu since it's pretty much the case)

Edit: Here is the output of "sudo aplay -l"

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

My primary sound card (i.e. not the external MOTU one) comes from my motherboard, it's a Gigabyte Z68 HD (or something like that, will try to find the exact model).

share|improve this question
    
What soundcard do you have? –  Uri Herrera Mar 6 '13 at 4:04
    
@UriHerrera added the result of sudo aplay -l –  Alexandre P. Levasseur Mar 6 '13 at 12:00
add comment

1 Answer 1

up vote 0 down vote accepted

I do not have single clue why but here is what fixed my problem (completely by mistake):

Using pavucontrol I have disabled "GF110 High Definition Controller" and the sound will only work if "Built-in audio" is set to anything Analog. It will not work if the setting is digital. Can anyone comment on why that would happen ?

Thanks.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.