Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried almost everything I can think of and I couldn't find out why (through google) my grid hotkeys aren't working.

I'm using the grid plugin for compiz .

share|improve this question
1  
What are grid hotkeys, in the context of Ubuntu One (or even Ubuntu)? –  Chipaca Feb 15 '11 at 13:30
    
The plugin for compiz –  Doug Feb 15 '11 at 19:45
    
This question appears to be abandoned - if you feel this is in error, then please ask a new question, or flag this explaining why and the moderators will reopen it. –  jrg Dec 21 '11 at 17:49
add comment

closed as too localized by jrg, Marco Ceppi Dec 21 '11 at 18:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Ive just tested, and mine work perfectly.

2 wild guesses:

  • Did you ever / recently change your LOCALE settings? Yes, i know it sounds absurd, but compiz have several bugs regarding locales and settings. Some of the settings have localized (translated) names, and if you set them using a given locale and then switch to another locale, the translated names get lost, and settings end up badly messed up. I could only fix mine when I changed every setting to a different value, so the localizations were wiped off the settings

  • Ever tried to change the default key assingments to other, say, "ordinary" values? The default ones uses the numeric keypad, and they are very problematic (mainly due to the numlock feature)

There are true "shot in the dark", for more accurate help i would need more details

But, given youre offering a beefy bound for it, I assume you desperatly need this. So, have you tried those "emergency" measures...

  • Reinstall compiz via synaptic

  • Uninstall compiz via synaptic, using the Complete Removal option?

This would delete its config files, and maybe would solve the issue.

share|improve this answer
    
I didn't really understand the locale settings thing. I am new to Ubuntu, forgive me. I am testing the complete removal of compiz solution.. –  Doug Feb 20 '11 at 8:05
    
Tried the hotkey changes before, and tried the reinstall. No good. Ask away, I am desperate, and I am using 64bit. –  Doug Feb 20 '11 at 8:35
    
Actually, I just tried to set my hotkeys in some other plugin called Viewport switcher ( which I don't know what it is) and the hotkey for that wasn't responding either. –  Doug Feb 20 '11 at 8:48
    
Just remember that a complete removal or compiz is a VERY deastic solution, and it could break your system. If you do that, first COMPLETELY DISABLE it before, and test if everything works fine. (Go to Menu -> Preferences -> Appearance -> Visual Effects -> None). Reboot, login, and test. THEN remove the package –  MestreLion Feb 20 '11 at 10:05
    
My visual effects were already at none when I first did the remove. Is there anything I should try? –  Doug Feb 20 '11 at 19:14
show 1 more comment

Try removing the ~/.compiz directory and then logging out and back in. This solved the problem for me.

http://ubuntuforums.org/showthread.php?p=10487226

share|improve this answer
    
I don't even see a .compiz directory in my home. –  Doug Mar 7 '11 at 7:43
1  
Hidden directories start with a ".". You can see them in Nautilus after pressing CTRL-H. Press CTRL-H again and the directories starting with "." are hidden again. –  bdr529 Apr 14 '11 at 7:58
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.