Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

You must know :

I have A ASUS laptop with NVidia Geforce GT 220M 1GB Running Windows 7 and Ubuntu 12.04 LTS.

All the drivers are Up to date, and actually i updated My Nvidia card 2 weeks ago and there was not problem with GRAPHICS just with wifi detector, but that was solved

suddenly 1 week ago :

When I start the Ubuntu from GRUB menu, i see the purple for 0.25 second after that I am stuck under 12.04 low graphic logo without Entering the System

enter image description here

I can access Startx with no Wifi and no programs and just few basic programs i tried the repairing from GRUB menu but no use, also going back to a previous version didn't solve a thing.

Today I found this when I tried to start Ubuntu

Ubuntu 20.04 LTS ab ... tty1
Username login : * starting mount network filesystems
*stopping mountnetwork systems

I accessed the command line and wrote :

Sudo startx

It asked me for Username and password then a black screen, after that


xinit : giving up
xinit : unable to communicate to X server no such file on directly 
xinit : Server Error

I tried

sudo apt-get update
sudo apt-get upgrade

But I noticed that it showed in the end of the upgrade that there is no space enough for the last upgrades, I couldn't follow what are they if that is important

update 3/9/2013

When I started Ubuntu Today It showed me this screen for less the none second

enter image description here

Written under It BETA DRIVER In red

Any Ideas, thanks you for reading

share|improve this question
Harry - your screen examples are confusing - you mentioned that you have installed 12.04 but one screenshot has ubuntu 11.04, another says ubuntu 20.04 (typo?). You also mentioned you ran out of space - this is never a good sign. Can you confirm this i.e. boot into recovery mode and type df -k - what is the output? – fossfreedom Mar 9 '13 at 23:27
NO NO, I didn’t say that is a screen shot it is what I found on google, my version is 12.04 and unfortunately I upgraded to 13.04 LTS, I tried my best but no one knew the solution, and I have work to do, excuse me for not explaining the Picture clearly but I was focusing on finding the solution not the Photo – Abdulkader Mar 9 '13 at 23:39
as for the Space you I only had like 100 M out of 40 G so yes I confirm, thanks for you effort man I will always put that In mind – Abdulkader Mar 9 '13 at 23:48
oh dear! looks like then you have either an alpha/beta issue with 13.04 - or because of the lack of space - the upgrade has gone wrong during the upgrade. 13.04 is not an LTS release - its is still in development. I've no idea how you managed to install 13.04 from 12.04 - it isnt normally possible - you have to install 12.10 first. Best advice is to boot with a live CD, backup your data and reinstall from the beginning. – fossfreedom Mar 10 '13 at 9:55

The first step to recover your system should be fix the space problem and repair potentially broken packages.

Please follow this little guidance:

  1. boot to recovery mode or use arescue cd
  2. open a shell
  3. set an environment variable rootPartition for later use. It should contain the device holding the root partition of your damaged installation
  4. Run the following command. Please review if before and check that all assumptions are correct, e.g. the ext4 file system. (It is copied from my notepad.)

    rootPartition="$(echo /dev/mapper/*-root)" 
    mkdir /target
    mount ${rootPartition} /target
    # preserve network resolution
    cat /etc/resolv.conf  >/target/etc/resolv.conf 
    # special file systems 
    mount -o bind /dev /target/dev
    mount -o bind /sys /target/sys
    mount -t proc none /target/proc
    # for grub, update-initramfs, ...
    # * use correct mount table (existing is not in sync!)
    # * prepend the correct view of the root partition (needed for update-initramfs)
    { echo ${rootPartition} / ext4 rw 0 0
      cat  /proc/mounts 
    } > /target/etc/mtab # for grub reinstallation
    # switch 
    chroot /target /bin/bash 
  5. Now you are in your broken installation. You may try to mount additional partitions like /usr/ if needed.

  6. Inspect your running low of diskspace problem and do the right steps to solve it. If you need assistance here, I`m sure you may find already the required hints on askubuntu.
  7. Don't forget to ensure that the installation is in a sane state:
    • dpkg --configure -a
    • apt-get update
    • apt-get install -f
  8. Reinstall the nvidia drivers packages
    1. ensure to remove the current drivers dpkg --purge --force-depends "nvidia*
    2. install again: apt-get install -f nvidia-current

On the first image is ubuntu 11.04 shown. So you should also ensure that your system is really upgraded to 12.04.

  • Check /etc/apt/sources.list and /etc/apt/sources.list.d that all references to natty are removed and the repositories for precise are declared.
  • Enforce an upgrade: apt-get dist-upgrade

With a little bit luck you can reboot back to a running installation.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.