Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a K8N NEO4 motherboard with a built in AC'97 sound card. It has a digital spdif output I wish to utilize.

My reciever is a Denon AVR 1709 which supports afaik DTS/AC3 in 44100 & 48000 hz. (It works with ATV2+xbmc+spdif/passthrough).

uname -a:

Linux monster 3.5.0-25-generic #39~precise1-Ubuntu SMP Tue Feb 26 00:07:14 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lsmod|grep snd:

snd_intel8x0 38578 3

snd_ac97_codec 134870 1 snd_intel8x0

ac97_bus 12767 1 snd_ac97_codec

snd_pcm 97523 3 snd_intel8x0,snd_ac97_codec

snd_seq_midi 13325 0

snd_rawmidi 30750 1 snd_seq_midi

snd_seq_midi_event 14900 1 snd_seq_midi

snd_seq 61931 2 snd_seq_midi,snd_seq_midi_event

snd_timer 29990 2 snd_pcm,snd_seq

snd_seq_device 14498 3 snd_seq_midi,snd_rawmidi,snd_seq

snd 83674 12 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

soundcore 15092 1 snd

snd_page_alloc 18573 2 snd_intel8x0,snd_pcm

aplay -L:

default
    Playback/recording through the PulseAudio sound server
sysdefault:CARD=CK804
    NVidia CK804, NVidia CK804
    Default Audio Device
front:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    Front speakers
surround40:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    4.0 Surround output to Front and Rear speakers
surround41:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804 - IEC958
    IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    Direct sample mixing device
dmix:CARD=CK804,DEV=2
    NVidia CK804, NVidia CK804 - IEC958
    Direct sample mixing device
dsnoop:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    Direct sample snooping device
dsnoop:CARD=CK804,DEV=2
    NVidia CK804, NVidia CK804 - IEC958
    Direct sample snooping device
hw:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    Direct hardware device without any conversions
hw:CARD=CK804,DEV=2
    NVidia CK804, NVidia CK804 - IEC958
    Direct hardware device without any conversions
plughw:CARD=CK804,DEV=0
    NVidia CK804, NVidia CK804
    Hardware device with all software conversions
plughw:CARD=CK804,DEV=2
    NVidia CK804, NVidia CK804 - IEC958
    Hardware device with all software conversions
a52:CARD=CK804
    NVidia CK804

Current settings (changes vs stock):

/etc/pulse/daemon.conf

default-sample-channels = 6

enable-lfe-remixing = yes

/etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=auto

This is my alsamixer: http://imgur.com/ay3t8T8.png

This is my pacmd / list-sinks output: http://i.imgur.com/j88fZ67.png

 >>> list-sinks
 1 sink(s) available.
   * index: 0
    name: <alsa_output.pci-0000_00_04.0.iec958-ac3-surround-51>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY 
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9958
    volume: 0: 100% 1: 100% 2: 100% 3: 100% 4: 100% 5: 100%
            0: 0.00 dB 1: 0.00 dB 2: 0.00 dB 3: 0.00 dB 4: 0.00 dB 5: 0.00 dB
            balance 0.00
    base volume: 100%
                 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 6ch 44100Hz
    channel map: front-left,front-right,rear-left,rear-right,front-center,lfe
                 Surround 5.1
    used by: 0
    linked by: 1
    fixed latency: 95.99 ms
    card: 0 <alsa_card.pci-0000_00_04.0>
    module: 4
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = ""
        alsa.id = ""
        alsa.subdevice = "0"
        alsa.subdevice_name = ""
        alsa.device = "0"
        device.string = "a52:0"
        device.buffering.buffer_size = "50796"
        device.buffering.fragment_size = "16932"
        device.access_mode = "mmap"
        device.profile.name = "iec958-ac3-surround-51"
        device.profile.description = "Digital Surround 5.1 (IEC958/AC3)"
        device.description = " Digital Surround 5.1 (IEC958/AC3)"
        alsa.card = "0"
        alsa.card_name = "NVidia CK804"
        alsa.long_card_name = "NVidia CK804 with ALC850 at irq 22"
        alsa.driver_name = "snd_intel8x0"
        device.bus_path = "pci-0000:00:04.0"
        sysfs.path = "/devices/pci0000:00/0000:00:04.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "10de"
        device.vendor.name = "NVIDIA Corporation"
        device.product.name = "CK804 AC'97 Audio Controller"
        device.form_factor = "internal"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"

I have also fiddled around a lot in Unity, pavucontrol, the standard audio settings etc. Nothing seems to help.

At some points in my travels I have managed to get white noise out in the front speakers. I have also once managed to get normal stereo sound out once.

"speaker-test -c6 " sometimes (sometimes as with some certain settings) produces white noise in two channels (never all 6).

I dont have sound out from my normal 3.5mm stereo plugs either, neither front or back.

I have tried reinstalling alsa/pulseaudio many times, also reverting back to complete stock settings with no measurable successes.

Sorry about the images, I cant copy-paste the text properly formatted for some reason.

Is it possible something defaults to use the analog spdif instead of the optical? Is there some idiot-safe way to get this working? Right now I would be happy to even have a reliable way to produce analog (3.5mm) stereo output just to make sure there isnt something fundamentally broken.

share|improve this question
add comment

1 Answer 1

This worked for me and my onboard sound...

  1. Run the following command in a terminal:

    sudo nano /etc/modprobe.d/alsa- base.conf
    
  2. And add the following line at the end

    options snd-hda-intel model=3stack
    
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.