Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 4 5830's in a intel 64bit powered machine.

I was having troubles with windows last night so I decided to try Ubuntu. I got all the to downloading and installed AMD's catalyst control center 13.1 for ubuntu.

My problem is:

I can run

$ sudo aticonfig --lsa
[sudo] password for user: 
 * 0. 01:00.0 ATI Radeon HD 5800 Series

 * - Default adapter

and find the first card in the first PCI lane. But none of the rest seem to show up even when I did

$ sudo aticonfig --adapter=all --initial
$ sudo rebot
$ sudo aticonfig --adapter=all --odgt

 Adapter 0 - ATI Radeon HD 5800 Series
        Sensor 0: Temperature - 67.00 C

I think the main problem is updating the MOBO BIOS which I am still trying to accomplish, does anyone know any solution to the issue I face above though?

I am trying to overall accomplish this http://www.distrogeeks.com/install-cgminer-2-10-4-ubuntu/

To install CGMiner on Ubuntu and get back to my mining!

EDIT: I had posted a response on here from another account but I think this "Bruno" guy deleted it, as it was not from this account.

I ended up removing linux (it crashed, couldn't display anything??) and installed windows. Turned windows on, installed mobo drivers, worked perfectly? Detected all cards first try.......

That only thing I think fixed my problem was just moving the cards, and turn the computer on and off until it recognized them all. Other than that, that is the only fix.

share|improve this question
    
This issue has been solved. Not sure of the fix. I literally kept switch around cards until it recognized all of them... –  BumSkeeter Mar 6 '13 at 1:05

2 Answers 2

Try to install additional driver from system settings>aditional drivers.

share|improve this answer
    
What will this do? What is in the "additional drivers"? –  user1596244 Mar 5 '13 at 13:00
    
This is a tool to install open source drivers for ubuntu –  Qeoqle Mar 5 '13 at 13:05
    
@user1596244, It will detect if there are additional drivers available for your computer and give you the option to install them. –  Chris Wilson Mar 5 '13 at 13:38
    
@Qeoqle OP already has drivers up and running, this answer is useless to the point where there are already drivers installed and running on the system. –  Bruno Pereira Mar 5 '13 at 14:02

You need to find the bus id of each card with lspci | grep VGA and add each card to your /etc/X11/xorg.conf file as such

Section "Device"
        Identifier  "Card1"
        Driver      "fglrx"
        BusID       "PCI:1:1:0"
EndSection

Section "Device"
        Identifier  "Card2"
        Driver      "fglrx"
        BusID       "PCI:1:2:0"
EndSection

You can edit your xorg.conf file with any text editor, but you will need sudo rights for that.

share|improve this answer
1  
This makes sense, I will see if I can do this when I get home. So lspci will list all hardware on the pci buses? –  user1596244 Mar 5 '13 at 14:30
    
Yes, and grep VGA will show you only the graphics card information. –  Bruno Pereira Mar 5 '13 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.