Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After finding out How to make Caps Lock change keyboard layout without delay

I realized that I'm also not fully releasing the Caps Lock sometimes before pressing next key. Is that possible to prevent it waiting for the keyup event?

share|improve this question
    
The answers from #2 on in this thread might interest you, @int_ua. Try grp:caps_switch and grp:caps_toggle. See if this command works for you: setxkbmap -layout 'us,ua,ru' -option 'grp:caps_toggle' & –  Glutanimate Mar 8 '13 at 3:54
    
I already use caps_toggle. The problem is that I type quite fast and sometimes start typing characters before releasing the Caps Lock so the layout doesn't change. –  int_ua Mar 8 '13 at 5:58
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.