Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude D430 laptop and I am unable to get the CPU to scale up to it's max 1200MHz. I have installed the indicator-cpufreq tool and also the cpufrequtils package. However, my CPU is stuck at 800MHz. Running cpufreq-info gives some interesting information:

segin@darvos:/etc$ cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 1.20 GHz
  available frequency steps: 1.20 GHz, 800 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  cpufreq stats: 1.20 GHz:46.82%, 800 MHz:53.18%  (647303)

analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 1.20 GHz
  available frequency steps: 1.20 GHz, 800 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  cpufreq stats: 1.20 GHz:46.44%, 800 MHz:53.56%  (599777)

Now, if I attempt to set the CPU governor to another governor, the policy still specifies the same frequency range. Attempting to specify a new maximum frequency with sudo cpufreq-set --related --max 1200MHz gives no error but has no effect. Attempting sudo cpufreq-set --related --min 1200MHz --max 1200MHz generates the 'Error setting new values' error message. Removing --related does not change the outcome of each attempt.

How can I change the CPU scaling settings so that I can lock it to 1200MHz all day, every day? This laptop has a battery used well beyond it's lifespan, so it's always connected to a charger, and a 90W one at that.

share|improve this question
add comment

1 Answer

First make sure that you are connecting to a quality AC source. I had my machine plugged into a long extension cord, and that was par of the problem.

Next, assuming the Dell Bios is getting in the way, try this:

Edit /etc/default/grub

Add processor.ignore_ppc=1 to the GRUB_CMDLINE_LINUX_DEFAULT line.

run sudo update-grub

Reboot the computer.

This is from http://www.woolie.co.uk/article/dell-laptop-stuck-800mhz-linux-fix/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.