Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just received my Nexus 4 and I want to plug it in to root it/copy files onto it but somehow I can't see it while I use

$sudo fastboot devices

I am using this version of fastboot on my ubuntu laptop

android-tools-fastboot 4.1.1+git20120801-1


While the issue of rooting the device was solved (simply fastboot only sees devices while they are in bootloader) I still cannot see the device while I plug it in the system.

share|improve this question
up vote 4 down vote accepted

You can update your gvfs file to enable your computer to see Nexus 4 files. Use the ppa

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update && sudo apt-get upgrade

After you update, reboot your computer. When you connect the Nexus 4 to the PC, make sure its unlocked. This should help you. :)

If you are trying to use adb and cannot see your device, change the ownership of your ~/.android folder to the current user .

sudo chown -R $USER:$GROUP ~/.android

For more details see here.

share|improve this answer

The Nexus 4 does not have a mass storage mode. I recommend using AirDroid instead, as it will allow you to upload/download/manage files on your Nexus device remotely.

share|improve this answer
His question was a bit unlcear, he wanted to have developer access via fastboot or adb, AirDroid dosen't provide that functionality. – LiveWireBT Jun 14 '13 at 21:42

The problem was that I have had "fast USB charge" option checked in kernel that I have installed

After unchecking that I can see folders on my Nexus 4.

share|improve this answer

Check the following link out. It worked for me.

share|improve this answer

Per Nexus 4 not detected as USB device with OTA update 4.3

Settings → Storage → ⋮ → USB-connection to computer → MTP media device ☑

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.