Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP Envy DV7 7212 with the GeForce GT 650M. I dual boot Windows 8 and Linux 12.10, Quantal. The video hardware operates properly under Windows 8. The Linux drivers are not loaded by the time that I try to login to X.

I get what looks like a safe X boot screen at 600x800 resolution

I've generated a great number of log files and reference some of their data here

nvidia-installer.log for the 313.18 installer shows no errors and successful completion

I've added blacklist entries in /etc/modprobe.d/blacklist.conf for nouveau and nvidiafb and my lsmod does not show them loaded. Though, the nvidia module is loaded with 0 users associated with it.

The system is running :

Linux TheTurk 3.7.0-030700-generic #201212102335 SMP Tue Dec 11 04:36:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

lsb_release produces the following output

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:   quantal

Using the nvidia-debugdump tool to list graphics devices I receive the following output

Found 1 NVIDIA devices
    Device ID:              0
    Device name:            GeForce GT 650M
    GPU internal ID:        GPU-1641f115-0090-aa40-d0ff-ae73bf5e3f85

lsmod provides a number of output items, however, the following are key

...
nvidia               9139978  0 
...
uvcvideo               82215  0 
videobuf2_core         36138  1 uvcvideo
videodev              130085  2 uvcvideo,videobuf2_core
videobuf2_vmalloc      12861  1 uvcvideo
videobuf2_memops       13405  1 videobuf2_vmalloc
...
video                  19413  1 i915

lshw -C display

produces the following output

*-display UNCLAIMED
   description: VGA compatible controller
   product: GK107 [GeForce GT 650M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list
   configuration: latency=0
   resources: memory:72000000-72ffffff memory:40000000-4fffffff memory:50000000-51ffffff ioport:4000(size=128) memory:52000000-5207ffff   
*-display
   description: VGA compatible controller
   product: 3rd Gen Core processor Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:45 memory:73000000-733fffff memory:60000000-6fffffff ioport:5000(size=64)

lspci -vnn | grep '\''[030[02]]'

produces the following

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107 [GeForce GT 650M] [10de:0fd1] (rev a1) (prog-if 00 [VGA controller])

Xorg.0.log shows some errors claiming

    ... 
[    24.355] Initializing built-in extension DRI2
[    24.355] (II) LoadModule: "glx"
[    24.593] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    26.822] (II) Module glx: vendor="NVIDIA Corporation"
[    26.822]    compiled for 4.0.2, module version = 1.0.0
[    26.822]    Module class: X.Org Server Extension
[    26.822] (II) NVIDIA GLX Module  313.18  Wed Jan  9 15:34:35 PST 2013
[    26.845] Loading extension GLX
[    26.845] (II) LoadModule: "nvidia"
[    26.845] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    27.003] (II) Module nvidia: vendor="NVIDIA Corporation"
[    27.003]    compiled for 4.0.2, module version = 1.0.0
[    27.003]    Module class: X.Org Video Driver
[    27.060] (II) NVIDIA dlloader X Driver  313.18  Wed Jan  9 15:15:26 PST 2013
[    27.060] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    27.076] (++) using VT number 7

[    27.076] (EE) No devices detected.
...
[    28.531] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found) 
...

Having discovered that this could be an Optimus issue. I've installed Bumblebee according to their recommendations http://bumblebee-project.org/install.html#Ubuntu However, I've ended up with some further issues. I'm searching for information on these, but I thought I'd go ahead and record them here for posterity.

First off, I get to the lightdm login screen just fine, but when I enter my password, I end up crashing the X server, or lightdm, and getting sent back to the login prompt, the login prompt reloads with that familiar chiming sound and further attempts to login result in the same crash and prompt repeating.

/var/log/upstart/bumblebee.log repeats the following 2 messages :

ls: cannot access /usr/lib/nvidia*/libGL.so: No such file or directory /proc/self/fd/9 31: exec: /usr/sbin/bumblebeed: not found

the first message is odd because /usr/lib/nvidia-current/libGL.so does exist the second is string because /usr/sbin/bumblebeed exists

/var/log/upstart/lightdm.log repeats this message :

** (process:12342): WARNING **: Error reading existing Xauthority: Error opening file: Permission denied Error writing X authority: Error opening file '/home/gary/.Xauthority': Permission denied

/var/log/syslog repeats this message :

bumblebeed[]: Module 'nvidia-current' is not found

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

For installing the nvidia 313 driver properly.

Do this commands:

sudo add-apt-repository ppa:xorg-edgers/ppa 
sudo apt-get update

Then go to your additional driver page and select the nvidia 313 driver. Wait until the driver is installed and reboot.

This ppa also include the nvidia-current package so it can fix your bumblebeed error.

(srr about the dutch language screenshot) enter image description here

share|improve this answer
    
That fixed the bumblebee error. After adding the repo that you cited above, I was able to add the additional driver through jocket. I wasn't able to get into the GUI, and so I used jockey-text --list to get a list of all of the appropriate drivers, then I enabled the driver for 313 through : jockey-text -e kmod:nvidia_313 –  OYRM Mar 5 '13 at 21:08
    
This worked for me with GTX 860M, annoying that standard ubuntu didn't make drivers available!! –  uzi3k Jun 21 at 20:37
add comment

The .XAuthority permission error was repaired by chown'ing the ~/.XAuthority file between Thomas15v's answer re: restricted drivers, and my own .XAuthority fix, along with the Bumblebee installation, I'm able to login and run optirun in an operational X environment.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.