Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problem with my wired connection. To be more specific my laptop doesn't seems to "see" that I have plugged in a Ethernet cable on it.

I tried to download new drivers for my Ethernet card but I couldn't find any solutions. Maybe because I am new to Linux so I don't know very much how to manage the command in terminal.

OK I have insert the command and there are the results:

00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter [1039:0191] (rev 02)

For the second reply I don't know if the following is what you asked me:

Memory: 3.9 GiB
Processor: Intel® Core™2 Duo CPU P8800 @ 2.66GHz × 2 
OS type: 32 bit 

My Ethernet connection had some problem on Windows too. I have changed recently my internet provider and since then my Ethernet cable is not recognized by the laptop at that time I was still on windows. I thought that with Ubuntu the problem will be solved but unfortunately the problem still persist. Please if someone can help me to solve my problem I'll be thankful.

There is the results of the three first command you told me to do :

lsmod | grep sis190 sis190 22570 0

sudo modprobe sis190

ifconfig eth0 Link encap:Ethernet HWaddr 00:90:f5:90:81:7e
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:185 errors:0 dropped:0 overruns:0 frame:0 TX packets:185 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:22672 (22.6 KB) TX bytes:22672 (22.6 KB)

wlan0 Link encap:Ethernet HWaddr 00:25:d3:2c:3a:ae
inet addr:192.168.1.72 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::225:d3ff:fe2c:3aae/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:260 errors:0 dropped:0 overruns:0 frame:0 TX packets:363 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:71992 (71.9 KB) TX bytes:52000 (52.0 KB)

and the two last:

dmesg | grep -e eth -e sis190 [ 0.816667] sis190: sis190 Gigabit Ethernet driver 1.4 loaded [ 0.816728] sis190 0000:00:04.0: setting latency timer to 64 [ 0.816751] sis190: 0000:00:04.0: Read MAC address from EEPROM [ 0.904032] sis190: 0000:00:04.0: Realtek PHY RTL8201 transceiver at address 1 [ 1.416030] sis190: 0000:00:04.0: Using transceiver at address 1 as default [ 1.448235] sis190 0000:00:04.0: eth0: 0000:00:04.0: SiS 191 PCI Gigabit Ethernet adapter at f8410000 (IRQ: 19), 00:90:f5:90:81:7e [ 1.448238] sis190 0000:00:04.0: eth0: GMII mode. [ 1.448243] sis190 0000:00:04.0: eth0: Enabling Auto-negotiation [ 11.560907] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 16.372019] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 16.372265] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 26.424038] sis190 0000:00:04.0: eth0: auto-negotiating...

nm-tool

NetworkManager Tool

State: connected (global)

  • Device: eth0 ----------------------------------------------------------------- Type: Wired Driver: sis190 State:
    unavailable Default: no HW Address:
    00:90:F5:90:81:7E

    Capabilities: Carrier Detect: yes

    Wired Properties Carrier: off

share|improve this question
    
Please open a terminal. Enter this code and press Enter: lspci -nn | grep 0200. The pipe symbol | is on the right-side of my US keyboard on the same key with \. The terminal will report back details about your ethernet card. Edit your question to add those details and we'll proceed. –  chili555 Mar 4 '13 at 21:03
    
What hardware (laptop model) are you on? Does it work when booted in Windows? –  DrSAR Mar 4 '13 at 21:49
    
I am ready to proceed @chili555 if you can help me trouble-shoot my problem thank you. –  Psallas Vassilios Mar 6 '13 at 14:40
add comment

2 Answers

Your ethernet device uses the driver sis190. Is it loaded?

lsmod | grep sis190

If not, load it manually:

sudo modprobe sis190

Does your ethernet come to life?

ifconfig

If so, let's get it to load automatically on boot:

sudo su
echo sis190 >> /etc/modules
exit

If your ethernet doesn't connect as expected, look for error messages:

dmesg | grep -e eth -e sis190

See if the system recognizes that a cable is attached:

nm-tool
share|improve this answer
    
when I do the command lsmod | grep sis190 the terminal gives me this sis190 22570 0 Is this mean that it's loaded? –  Psallas Vassilios Mar 6 '13 at 15:38
    
Exactly. So go on to the other questions: dmesg | grep -e eth -e sis190 and nm-tool. –  chili555 Mar 6 '13 at 15:56
    
OK I have edited my question with the data you asked me ... –  Psallas Vassilios Mar 6 '13 at 16:09
    
'carrier: off' suggests the cable or the port at the router are defective. Can you try another cable and another port at the router? On the other hand, 'autonegotiating' suggests it's at least trying. I see nothing remarkable that needs fixing with the driver. –  chili555 Mar 6 '13 at 16:16
    
OK I tried both of your suggestions. There is apparently no problem with the cable or the port of the modem because I have a notebook (which have Ubuntu 12.04 installed too) that connects perfectly. So what are you suggesting if there is something to suggest.... ( thanks for your time ). –  Psallas Vassilios Mar 6 '13 at 22:05
show 6 more comments

I had a similar problem a few months ago with one of my laptops (a Dell Inspiron E1505, though I don't think that the answer below is dependent on your laptop being the same model). I realize that there are multiple causes for an ethernet jack not recognizing that a cable is connected to it. Having said that, this might be worth trying the steps below before you do a lot of troubleshooting.

This answer comes from http://vittalp88.blogspot.com/2011/03/network-cable-unplugged-but-it-isnt.html. I'm hoping I don't get down-voted just because it sounds so ridiculous. With my own laptop, I only tried it after several hours of troubleshooting. However, this solution worked (though I'm not sure why; neither is the author of the linked post, apparently):

1) Turn your laptop off. 2) Unplug the battery. 3) Leave it (with battery unplugged) for an hour. 4) Put the battery back in, boot up, and see if the ethernet jack is working again.

Perhaps it's worth trying this before doing much else?

(Note: The link above talks about having this problem in Windows. When I used the solution, it fixed the same problem in Ubuntu 12.04)

share|improve this answer
    
OK I have tried this but with no success ... thank you for the reply but it seems more complicated unfortunately –  Psallas Vassilios Mar 5 '13 at 9:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.