Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since the installation of Ubuntu 12.10 on my laptop today it has been refusing to start Xorg when booting on occasions. Randomly it works but about 75% of the time it either gives me a black screen with login prompt or the fail safe mode, the latter being the most common.

Using CTRL+ALT+F1 to go to a terminal like screen, I managed to crack open the /var/log/Xorg.0.log file on the "faulty" boot process. Here are some lines which look interesting to me:

(EE) intel(0): [drm] Failed to open DRM device for pci:0000:00:02.0: No such file or directory
(EE) intel(0): Failed to become DRM master.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found

It is apparently loading the "vesa" driver package.

Specs of my laptop:

  • CPU: Intel Core i5 2450M
  • GPU: Intel HD Graphics 3000
  • RAM: 8 GB DDR3
  • OS: Windows 8 + Ubuntu 12.10 (fully updated)

Any ideas? Any suggestions are very welcome, even if they don't work as expected.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I've had the same issue, the first workaround described in ubuntu-lightdm-black-screen on webup8.org solved it for me. Seems to be a timing issue with LightDM and mostly SSD's.

share|improve this answer
    
Thank you! I forgot to mention that I am indeed using an SSD in my laptop. I'll try the suggestion in that blog and report back :) Thanks again! –  Rick Kerkhof Mar 4 '13 at 18:55
    
Wow, just added that single line and everything works now... Amazing how my SSD is "too fast" for Ubuntu, lol. Thank you once more :) Do you think this will be fixed with 13.04 by default? –  Rick Kerkhof Mar 4 '13 at 19:04
1  
Whilst this may answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  guntbert Mar 4 '13 at 20:45
    
Tim, thanks. Maybe this will get fixed with the "upcoming" new window manager (if it's included in 13.04). We'll see :) –  Rick Kerkhof Mar 4 '13 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.