Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Realtek RTL8191SEvB wireless card on Ubuntu 10.10:

$ lspci -v | grep Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

When I load its driver, according to the Network Manager it sometimes blinks with a list of available networks but it keeps disabling itself or it stays disconnected. So, I can't connect to any wi-fi network (which results in frustration).

The driver is loaded:

$ lsmod

Module                  Size  Used by
r8192se_pci           509932  0 

Looks normal:

$ sudo lshw -C network

*-network               
     description: Wireless interface
     product: RTL8191SEvB Wireless LAN Controller
     vendor: Realtek Semiconductor Co., Ltd.
     physical id: 0
     bus info: pci@0000:03:00.0
     logical name: wlan0
     version: 10
     serial: 1c:65:9d:60:c7:7a
     width: 32 bits
     clock: 33MHz
     capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
     configuration: broadcast=yes driver=rtl819xSE driverversion=0019.1207.2010 firmware=63 latency=0 link=no multicast=yes wireless=802.11bgn
     resources: irq:17 ioport:2000(size=256) memory:f0500000-f0503fff

Configured:

$ sudo iwconfig wlan0 

wlan0     802.11bgn  Nickname:"rtl8191SEVA2"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Bit Rate:130 Mb/s   
          Retry:on   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=10/100  Signal level=0 dBm  Noise level=-100 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Is not blocked:

$ rfkill list all

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: yes

However something's happening with it:

$ dmesg

[ 6485.948668] InitializeAdapter8190(): ==++==> Turn off RF for RfOffReason(1073741824) ----------
[ 6486.062666] rtl8192_SetWirelessMode(), wireless_mode:10, bEnableHT = 1
[ 6486.062671] InitializeAdapter8192SE(): Set MRC settings on as default!!
[ 6486.062675] HW_VAR_MRC: Turn on 1T1R MRC!
[ 6486.064091] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6486.248761] rtl8192_SetWirelessMode(), wireless_mode:10, bEnableHT = 1
[ 6486.248771] InitializeAdapter8192SE(): Set MRC settings on as default!!
[ 6486.248776] HW_VAR_MRC: Turn on 1T1R MRC!
[ 6486.580083] GPIOChangeRF  - HW Radio OFF
[ 6486.610085] ============>sync_scan_hurryup out
[ 6486.623814] ================>r8192_wx_set_scan(): hwradio off
[ 6486.830484] =========>r8192_wx_set_essid():hw radio off,or Rf state is eRfOff, return

So, does anyone know where the problem might be?

share|improve this question
    
I used to have this problem. Seems pretty stable now (11.04), but I still see a lot of logging in dmesg that I don't like pertaining to this card. I think it's also dependent on the router, as I a vast number of disconnect problems with the hotel wifi, and almost no problems at home. –  Wolfger Jul 18 '11 at 18:05

1 Answer 1

In the Ubuntu Forums they recommend to download the driver from Realtek eg. http://218.210.127.131/search/default.aspx?keyword=rtl8192

share|improve this answer
    
Yes, this is what I did. See the driver link in the question. –  jindrichm Feb 14 '11 at 20:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.