Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the folowing error when I try to mount a drive:

Error mounting /dev/sda1 at /media/ubuntu/f2bebb2d-d57d-4c75-b719-cda5a73d8531: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda1" "/media/ubuntu/f2bebb2d-d57d-4c75-b719-cda5a73d8531"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda1,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

There are two partition on my hard disk. I have tried starting up with the install disk to see if there are any disk repair apps but it seem that there are not.

share|improve this question
2  
Please edit your question and tell us how you try to mount. –  Mostafa Shahverdy Mar 4 '13 at 17:54
    
The drive is the main system boot hd. I downloaded the install image and burned it to a dvd and booted of it. In the side bar the drive is listed and I double clicked on it. A few seconds later the error message pops up. –  user137559 Mar 4 '13 at 18:20
    
I have pulled the drive out an put it into an external case and see if I could mount it on my Mac. In the Disk utilities on the Mac it sees the drive but it will not mount the two partitions. –  user137559 Mar 4 '13 at 18:23

1 Answer 1

wrong fs type, bad option, bad superblock on /dev/sda1

Either you have used the wrong partition or the filesystem is seriously scrambled.

First double check that your intent is really to mount /dev/sda1.
Look at the output of:

parted /dev/sda print

If you're sure that it is the right partition, try to do a file system check:

e2fsck /dev/sda1

If you need further assistance add the output to your question.

share|improve this answer
    
I was able to find the disk app and it shows the two partitions a 1.1 gigs. It is a 320gb drive and it looks like it is not seeing the third filesystem drive. –  user137559 Mar 4 '13 at 21:41
    
how do I do it as a super user form the try now disc. I get a command not found with e2fsck –  user137559 Mar 5 '13 at 0:09
    
The server has been running with no problem. The two partitions are the file system and swap disk. I and see the partitions when I use the disk app on the instal disk running test/try now instead of install. I did come across this page superuser.com/questions/278864/cant-mount-hard-drive-ubuntu and it seems like the problem I am having. The only thing get privilege problems when I run off the disc (sudo). How can I do the test as a super user running of the disc. –  user137559 Mar 5 '13 at 15:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.