Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed VirtualBox via Software Center. When I try to load a VM, getting an error exactly like this:

Error window

After I googled this error, found many different solutions, none of them were helped my situation. Also I removed all packages associated with VirtualBox, then downloaded and installed the latest package which I downloaded from Oracle repositories. Nothing is changed.

Additional Information:

  • OS : Ubuntu 12.04 64-bit
  • VM : Linux Mint 14 Cinnamon/MATE 64-bit

I created new vdi disk and tried to start it from .iso image.

Virtualbox Settings:

  • Num of processors : 4
  • Memory : 512 MB
  • Video Memory : 128 MB
  • 3D Acceleration: Enabled
share|improve this question
add comment

3 Answers

The error message is pretty self explanatory. The VM you are trying to start needs hardware virtualization enabled. See the follwing Q&A on how to do so (provided your CPU is capable of this):

If this does not resolve the issue, the following steps may help:

  • Reboot the host OS
  • Try with fewer virtual CPUs starting from 1 only
  • disable VT-x settings in VBoxManager (reported to worked but I doubt this)
  • on a Hewlett Packard machine hardware VT-x could only be achieved with a BIOS update (source superuser.com)
share|improve this answer
    
it's already enabled. –  talha06 Mar 4 '13 at 9:33
    
Please add this valuable information to your question. In addition we also may need to know the architecture of host and guest and where the VM you try to start comes from. –  Takkat Mar 4 '13 at 9:41
    
ok, edited question; more information is added.. –  talha06 Mar 4 '13 at 9:46
add comment

Yes, for me that was the issue. Run the VB as an administrator. Right click on the VB, and select "Run as Administrator"

share|improve this answer
    
That looks like a Windows "solution" - in any case never run VirtualBox (or VMWare) as root/administrator. –  guntbert Jan 5 at 19:23
add comment

It's that you need to run Virtualbox as an administrator.

share|improve this answer
2  
Never run virtualbox/vmware as root! –  guntbert Aug 16 '13 at 15:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.