Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After an update to Unbuntu 12.04, the sound is now off. With Rhythmbox, I can barely hear the songs playing with the headphones connected, but nothing with the internal speakers.

I have a Sony Vaio PCG-7V2l with the following sound card hardware:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


$ cat /proc/asound/card0/codec* | grep Codec
Codec: SigmaTel STAC9872AK
Codec: Conexant ID 2bfa

The first thing I tried was to run alsamixer and the sound settings for volume control or mute being set. Everything looks normal and nothing muted. I then updated the sound drivers on 03/03/2013 and rebooted:

sudo add-apt-repository ppa:ubuntu-audio-dev
sudo apt-get update
sudo apt-get dist-upgrade

I added

'options snd-hda-intel index=0 model=vaio"

to the end of /etc/modprobe.d/alsa-base.conf

I also tried adding model=auto and model=generic to alsa-base.conf.

And I also tried killing pulseadio. with:

sudo killall pulseaudio; rm -r ~/.pulse*

Does anyone have any solutions to this problem?

Thanks.

share|improve this question
    
The bottom of the alsa-base.conf has: options snd-pcsp index=-2 # Keep snd-usb-audio from being loaded as first soundcard options snd-hda-intel model=vaio But the output from bash "alsa-info.sh --stdout¨ shows both model=auto and model=vaio: snd-usb-audio: index=-2 snd-hda-intel: model=auto snd-hda-intel: model=vaio Where is the model=auto coming from? I found a site that says I need to use model=vaio. –  user137321 Mar 30 '13 at 20:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.