Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently tried to install Ubuntu 12.10 x64 over x32 and it installed, but now the wireless won't work. I have a BCM 4312 card for the wireless. I've tried pressing the wifi button on the computer, but it just stays orange. Also, I've tried a lot of different things and "wl" is non existent on my computer. I'm still trying to get the hang of this, so please explain and help!

UPDATE: So, it turns out I just needed to update my kernel to 3.8. I followed the instructions found at this thread: Why has wireless disappeared after my 12.10 upgrade?

share|improve this question
1  
Please confirm the details of your wireless card from the terminal command: lspci -nn. –  chili555 Mar 3 '13 at 22:23
    
I think this is what you want: Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01) –  user137310 Mar 5 '13 at 0:11

1 Answer 1

Please get a temporary wired ethernet connection and open a terminal and do:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

You should be all set.

share|improve this answer
    
I tried that and get this: Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. –  user137310 Mar 5 '13 at 1:11
    
The installation of linux-headers is supposed to fix that. Please try: sudo apt-get install linux-headers-$(uname -r) Then do the steps in my answer again. Let me know if there is a further error. –  chili555 Mar 5 '13 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.