Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i went using the gui at first (software sources -> additional drivers), it installed without any problem, but when restarting and running sudo lshw -C display i still get this:

*-display               
   descripción: VGA compatible controller
   producto: G96 [GeForce 9500 GT]
   fabricante: NVIDIA Corporation
   id físico: 0
   información del bus: pci@0000:01:00.0
   versión: a1
   anchura: 64 bits
   reloj: 33MHz
   capacidades: pm msi pciexpress vga_controller bus_master cap_list rom
   configuración: driver=nouveau latency=0
   recursos: irq:16 memoria:a2000000-a2ffffff memoria:80000000-9fffffff memoria:a0000000-a1ffffff ioport:2000(size=128)

Notice the driver=nouveau part, i tried uninstalling the nvidia driver and reinstalling it on the console (using sudo apt-get install nvidia-experimental-310) and it installed sucessfull but again after rebooting and checking the nouveau drivers keeps coming... any help?

EDIT: i managed to install them properly... but then after rebooting i got stuck at 640x680 res, unity was glitchy and got a black bar at the left of the screen... i tried with nvidia-experimental-310, nvidia-experimental-304, nvidia-current and nvidia-current-updates with the same result.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I actually JUST redid this and got it working with snyaptics. Went smooth as could be. Make sure you select not only the driver itself but also the management console as well.

Packages are nvidia-experimental-310-dev nvidia-settings-experimental-310

Give that a shot.

share|improve this answer
    
i installed it again, but when running nvidia-settings I get an error saying You do not appear to be using the nvidia x driver. –  Hairo Apr 21 '13 at 0:32
1  
Ya I got that too the second time around. Run sudo apt-get uninstall nvidia*. It will strip out all the nvidia stuff. Then you can put the 310 stuff in with nothing else in the way. Reboot after each step and you should be fine. BEWARE - You may inadvertently kill your windows manager (lightdm, gnome etc) in which case you will boot into the terminal. You will need to do a reinstall of which WM you are using then reboot. I had to strip out ALL nvidia and lightdm then putt hem back for it to come back into a GUi environment. –  meteorainer Apr 22 '13 at 1:17
    
i'll try it when i get home, i was planning on making a clean raring install when it's released this week, and then install the drivers. –  Hairo Apr 22 '13 at 18:00
    
How'd it end up going? –  meteorainer Apr 23 '13 at 2:23
    
i tried it, but there wasn't any nvidia package installed, I'll try with a clean raring install later –  Hairo Apr 23 '13 at 22:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.