Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04.4 installed in my machine ( Acer 3810 T). With some recent kernel update (present kernel is 2.6.32.46) there is a problem with the microphone sound when I am using Skype. While making calls, I am able to hear the person on the other side, however I am not audible to the contact. This problem started when there was a kernel update from 2.6.32.43 to 2.6.32.45. I have searched the different forum questions where suggestions have been made to make PulseAudio Volume the default for Skype. I have install the above mentioned sound mixer, however still the problem remains. The AUDACITY recording tells me that the system microphone is otherwise fine. Hence right now I am clueless as to what might be the problem and the only thing I can conclude is there some bug in the recent kernel updates that I made.

Any immediate suggestion for solving this issue would be of much help !

share|improve this question

3 Answers 3

We may need another sound profile to be able to connect both, the microphone, and the audio for telephony usage.

To change the audio profile used with PulesAudio open "Sound Preferences.../Hardware, and try with the "Duplex" profile.

enter image description here

Audio profiles can also be changed with pavucontrol Install pavucontrol in case it is installed.

A solution from a previous answer suggested to switch microphone to mono by disabling one channel.

Disclaimer: unfortunately we can not test this possible solution, as we don not have Skype installed in our 10.04 test system, and a proprietary sound access may be used by Skype in this release.

share|improve this answer

I've hit a similar problem with sound recording during and after a Skype call in Ubuntu Lucid:

after a reboot, sound recording works (tested through arecord, record, audacity). When making a Skype call, for several first seconds sound is recorded ore or less fine (that's why when doing the Skype echo test it might seem that it works), but then most or all of the sound is omitted (so that ultimatey the other end hears only silence). After exiting from Skype, all recording test also fail, the recording results in an almost zero-length silence recording: ith arecord or audacity).

I've found out that pulseaudio is involved by default between Skype and the sound card.

So as a test, I've disabled pulseaudio (to see whether the problems would disappear): sudo chmod a-x /usr/bin/pulseaudio

And indeed, the problems have gone away.

So my simple recommendation is to disable pulseaudio (preferably--for those with basic Unix knowledge but without a wish to learn about pulseaudio configuration--simply by making it non-executable, because the correct way --deisntalling the package--might cause too much trouble with the dependencies).

As the next step, there is another issue to resolve, if you want to have a nice desktop environment: after you disable pulseaudio, the sound volume/mixer applet isn't working anymore because it relies on pulseaudio. So, you have to get another volume/mixer applet that is able to work directly with ALSA.

Solution for the mixer applet problem: among the mixers available in Ubuntu Lucid, the only one that can be minimized into an applet is kmixer (from KDE4). So, I've installed kmixer, configured it, and added it to the autostarts in the preferences menu.

share|improve this answer

I always find that unticking the skype default voice setup works when I install skype on PCs.

Start Skype normally.

Navigate down to Options>Sound Devices.

Spot the button below and untick it

enter image description here

As you can see I also have pulse audio running and they can sometimes conflict.

Let us know how you get on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.