Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

In late February 2013 I installed the latest updates on my Ubuntu 12.04 system (an Asus Eee 1215T), rebooted, and after that it was no longer able to make a network connection over wi-fi. It just repeatedly asks me for the WPA password. I enter it, but the connection is not made and it asks for the password again. I have made no changes to the wi-fi router for at least 6 months, and other wi-fi devices I have still connect without trouble. The only thing that changed was the Ubuntu update.

Update: After some digging, I have found the problem and a solution. Close reading of /var/log/syslog revealed that the computer was connecting to the wi-fi router without trouble, but it was failing the DHCP negotiation. Read my answer below for details, as soon as this question gets reopened. :) I'm leaving my old information in the question for reference, in case anyone finds it relevant.

BTW, for those that marked my question as a duplicate, I think it isn't. While the solution in the purported duplicate question's answers might have worked (I didn't try it), mine was a new problem introduced by a January 2013 Ubuntu update, and not the classic Broadcom problem reported in 2012, and it was solved with a different method.


dmsg shows the device as a BCM4727:

$ dmesg | grep -i bcm
[   20.632433] eth1: Broadcom BCM4727 802.11 Hybrid Wireless Controller 6.20.155.1 (r326264)

But lshw shows it as a BMC4313:

$ sudo lshw -C network
PCI (sysfs)  

  *-network               
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: 01
       serial: 48:5d:60:6d:d8:59
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:16 memory:fbefc000-fbefffff

The specifications page does not make the wi-fi chipset clear, unfortunately.

In case it is relevant, here is lsmod:

$ lsmod | grep wl
wl                   2906597  0 
cfg80211              178877  1 wl
lib80211               14040  2 lib80211_crypt_tkip,wl

I tried removing and reinstalling the Broadcom STA wireless driver through System Settings --> Additional Drivers, but that didn't help, even after a reboot.

The page WiFi problem after Ubuntu 12.10 update has some promising suggestions in its accepted answer, but seems to be specific to 12.10 and the BCM4312, not my (possibly) BCM4313. Any suggestions?

share|improve this question

marked as duplicate by Luis Alvarado Apr 16 '13 at 12:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Since you are still using the BCM43XX Drivers, the marked as duplicate question will still apply. Is not subjected to a specific time frame. The answer provided there will apply until Broadcom releases the complete source code to their Wireless cards. Even the BCM4727 which is actually a BCM4313 is shown in my answer there. If you test my answer out and you do not find any way of fixing this question, then by all means, please vote for reopen again. I will open the question for you. –  Luis Alvarado May 2 '13 at 3:09

1 Answer 1

Well reset your modem. It happened to me also but resetting worked. Mine is Asus EeePC 1025C. Let me know if it fails

share|improve this answer
    
By modem you mean my Linksys WRT54G router? –  Randall Cook Mar 3 '13 at 19:40
    
yes you have to do reset that only –  Janmejay Mar 8 '13 at 20:28
    
I power-cycled it, but the problem persists. –  Randall Cook Mar 11 '13 at 17:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.