Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I open my documents, all the folders in it are displayed with a lock icon. Therefore, I cannot delete any file or folder in it.

I tried changing the root access using sudo chmod user:directory/ but it fails. I am not able to delete or perform any file action with it.

What action should I perform to fix it?

share|improve this question
2  
Please take a screenshot from Permissions and post it (or upload it and put the link to it) here. To see permissions, right click on a folder or file and select Properties. –  AliNa Mar 3 '13 at 14:09
    
Hey I have same problem with ubuntu 13.10. But all folders turn locked suddenly. and I can't open any program even shutdown doesn't work. To execute commands >> no chance at all because no program open up including terminal too. ultimately i had to restart the machine. please suggest any method to get rid of this bug.. –  Mahesh Kanwate Apr 16 at 17:26

4 Answers 4

up vote 1 down vote accepted

Run this to fix your home directory permissions:

sudo chown -R $USER:$USER $HOME
share|improve this answer

This would happen probably because you downloaded something from the web. And you don't have the write access to the folders. If you are sure that the files are virus free, try the following command.

chmod -R +rw *

This will remove the lock icon from the nautilus.

share|improve this answer

sudo chmod 777 -R /path to folder you want to delete- This would give all permissions (Read, Write, Execute) to you

The permissions (in this case 777) are as follow:

  • 7 - Full (Read, Write & Execute)
  • 6 - read and write
  • 5 - read and execute
  • 4 - read only
  • 3 - write and execute
  • 2 - write only
  • 1 - execute only
  • 0 - none

after changing the permission, try and delete the folder

share|improve this answer
    
This would also allow anyone else to access the folder, including guests. –  Marco Scannadinari Mar 7 '13 at 18:32
    
thats why i have given you the explanation. use 757 instead of 777 then –  Janmejay Mar 8 '13 at 20:26

Open terminal and type

gksudo nautilus

Browse to the location of documents. Goto properties and set the permission for owner as well as group as read and write. Now try to delete the folder from another nautilus window (one without root privileges).

Don't forget to close that super user nautilus as soon as you don't need it any more!

share|improve this answer
2  
Never suggest sudo nautilus - gksudo nautilus is the recommended command - if really needed at all. –  guntbert Mar 3 '13 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.