Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I am trying to install git with the following command as listed on the git Linux download page:

sudo apt-get install git

After that command I get the following error:

Reading package lists... Done  
Building dependency tree       
Reading state information... Done   
E: Couldn't find package git

I am running Ubuntu 10.04 (as that is the recommended version for Android build environment).

I am pretty new to Linux so any help would be appreciated.

Thanks

share|improve this question
    
Okay so took a spare hard drive and installed Ubuntu 12.04.2 LTS this morning. Ran the same command as before: sudo apt-get install git. Git install with no problem. I am guessing at this point that the most current version of git is not available for 10.04. –  afskymonkey Mar 3 '13 at 20:09
    
Which mirror are you using? It may be out of date perhaps? Also, did you run apt-get update prior to trying the install? –  CraigM Mar 3 '13 at 20:51

1 Answer 1

up vote 5 down vote accepted

You want sudo apt-get install git-core.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.