Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a bit of a problem with my graphics drivers. My card is a Radeon HD 4850.

It all started when I tried to upgrade to the 13.1 Legacy Driver a few days ago. I was unable to generate a distribution-specific package. When I attempt to, the package generates, and the file appears in my current directory. When I click "exit", it says that the package generation failed, and the file is removed. I am able to copy the file to another location, but when I attempt to run "ati-installer.sh" in the terminal it exits straight away. The error log shows quite a bit of info, but I am unable to make sense of it.

I was, however, able to install it by using the general installer. It all installed well and seemed to be going fine. I restarted my computer, and it booted to the command line. I typed sudo apt-get install fglrx which fixed me from booting to the command line.

Now when I try to play Minecraft, it crashes and gives me this error log.

lspci | grep VGA
dmesg | grep AMD
glxinfo | grep direct

I've attempted a complete purge of fglrx and then a re-install via the command line, I've tried installing mesa-utils.

How might I go about fixing this problem?

EDIT: I've fixed the issue.

First I ran sudo apt-get install dh-modaliases, which allowed the packages to generate. Then I had to run sudo apt-get purge nvidia* as the aticonfig command wasn't able to install where it was supposed to because there were still parts of an nvidia driver laying around on my system. I thought I'd already uninstalled the nvidia drivers, but I guess not. After doing those two things I was able to generate and build and install the packages.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.