Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently trying to build gnome-settings-daemon from the upstream source. I first cloned the package using

git clone git://git.gnome.org/gnome-settings-daemon

then navigated into the directory and started the build process with

./autogen

However, I ended up with the following error:

checking for KEYBOARD... no
configure: error: Package requirements (xkbfile ibus-1.0 >= 1.4.99 gnome-desktop-3.0 >= 3.7.90) were not met:

No package 'ibus-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables KEYBOARD_CFLAGS
and KEYBOARD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I have the ibus and ibus-gtk3 packages installed, so I'm not sure what the actual problem is.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I've found two possible solutions to this. The first is to install the ibus development package (as opposed to the release package) using

sudo apt-get install libibus-dev

Alternatively, the build can be carried out without iBus at all by running

./autogen.sh --disable-ibus
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.