Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Scenario

Install Ubuntu 12.04LTS Server on a RAID10 with boot on a RAID1.

  • 4 - 2Tb SATA Hard Drives
  • 3 Partitions (/boot, /, and swap)
  • boot (256Mb from each disk) setup in RAID1 /dev/md0
    • partition is ext2 /dev/md0p1 should be where boot is loaded
  • swap and root partition (remaining disk space) setup in RAID10 /dev/md1
    • swap partition - 8Gb partition of RAID10, linux-swap /dev/md1p1
    • root partition - remaining space of RAID10 - GPT partition table, ext2 /dev/md1p2

We've setup our disks and RAID configurations using mdadm, fdisk, and parted while running the Ubuntu 12.04LTS Server Trial from a thumb-drive.

Installation fails at grub. I can't get past this. On one machine it fails at grub-dummy-install, and on the other it simply fails with grub. The latter of the machines has completed installation but asks to install bootloader at different location or not at all. Installer becomes unresponsive though if you choose "install at different location".

Goal

We want the OS loaded on the RAID10 but we want to make sure that if any drive fails the machine can still boot from /boot and find the OS on the RAID10.

What We Know

The alternative installer supports RAID10 configuration at installation, but does it achieve our goal without taking the same process in setting up the disks?

We know we should see our RAIDs in /dev/mapper/{array-name} but we don't, we only see control. This info I've gathered from this previous question

We followed instructions we've found here and here

What We Don't Know

  1. Is there a better way to do this and still achieve our goal?
  2. Why we're not seeing our disks in /dev/mapper/
  3. Most importantly: Why we can't install the boot-loader to our /boot partition, namely /dev/md0p1 at installation.

Updates

We're trying this out simultaneously on two machines. One gets this error "executing 'grub-install-dummy' failed. this is a fatal error" and the other gets "executing 'grub-install /dev/sda' failed. this is a fatal error" I'm under the impression that these are errors related to different portions of installing grub. Any Ideas?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.