Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm in the UAE, so I can not install skype from the software center. I made my friend upload a deb file and i downloaded it. I ran it with Gdebi package installer and I get the error:

libxss1 not satisfiable

I tried to install the libxss1:

sudo apt-get install libxss1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libxss1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libxss1' has no installation candidate
share|improve this question
1  
Skype needs quite a few libs to work. Have you tried sudo apt-get update? That usually fixes like the one you're having: "not available, but referred to by another package". Rounding up missing libs can be a real pain sometimes. Good luck! –  JamesTheAwesomeDude Mar 2 '13 at 16:05
    
I tried that. Didn't work :) ! –  Fred Mar 2 '13 at 17:08
    
Sorry, then. ;( I'm not very good myself at rounding up libraries... I hope you make it, though! :) –  JamesTheAwesomeDude Mar 2 '13 at 18:37
add comment

1 Answer 1

up vote 0 down vote accepted

Fire up a terminal using Control+Alt+T, then write:

sudo dpkg --install /Path/to/libxss1.deb

Ignore the errors, then:

sudo apt-get install -f

Then again:

sudo dpkg --install /Path/to/skype.deb

or if from repo, just:

sudo apt-get install skype

You should be able to install the package.

share|improve this answer
    
$ sudo dpkg --install /Path/to/libxss1.deb dpkg: error processing /Path/to/libxss1.deb (--install): cannot access archive: No such file or directory Errors were encountered while processing: /Path/to/libxss1.deb $ sudo apt-get install -f 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. $ sudo dpkg --install /Path/to/skype.deb dpkg: error processing /Path/to/skype.deb (--install): cannot access archive: No such file or directory Errors were encountered while processing: /Path/to/skype.deb –  Fred Mar 2 '13 at 17:41
    
looks horrible i'm sorry. –  Fred Mar 2 '13 at 17:42
    
/Path/to/libxss1.deb is the path to your downloaded libxss1.deb file :D . download it from packages.debian.org/search?keywords=libxss1 –  Mostafa Shahverdy Mar 2 '13 at 17:43
1  
facepalm! Thank you i installed it now. Now i just need to find it :) –  Fred Mar 2 '13 at 17:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.