Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the Rails 2.3.14 package by running:

sudo apt-get install rails

It is working fine. But after that I installed the Rails 3.2.9 gem by running:

gem install rails

In the terminal, rails -v gives me rails 2.3.14. If I run these two commands,

. ~/.bash_profile
rails -v

then I get rails 3.2.9.

I don't know what exactly is happening. Now I want just the Rails 3.2.9 gem. What should I do to get that?

share|improve this question
add comment

2 Answers

So you want to uninstall Rails 2.3.14?

Try this: gem uninstall rails and it should show you all the versions and you pick the one you want to uninstall.

if that doesn't work try sudo apt-get remove rails

For more help try this thread as I'm in a similar boat trying to install rails correctly (just installed Ubuntu):

http://stackoverflow.com/questions/7154498/rails-v-returns-2-3-5-but-gem-uninstall-rails-offers-to-uninstall-version-3-1

share|improve this answer
add comment

Better to follow this blog to install Ruby on Rails this way as I didn't have any issues when I followed step by step the blog said: http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.