Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to build rhythmbox from source to have a go at adding an extra feature. I'm running into issues with gstreamer

configure: error: Package requirements (    gstreamer-1.0 >= 0.11.92
gstreamer-audio-1.0 >= 0.11.92
gstreamer-base-1.0 >= 0.11.92
gstreamer-plugins-base-1.0 >= 0.11.92
gstreamer-pbutils-1.0 >= 0.11.92) were not met:

No package 'gstreamer-audio-1.0' found 
No package 'gstreamer-plugins-base-1.0' found
No package 'gstreamer-pbutils-1.0' found

I've tried what's in this post,

sudo apt-get build-dep rhythmbox

and installing some of the gstreamer packages to no avail.

share|improve this question
add comment

1 Answer 1

up vote 7 down vote accepted

Maybe you need to install the devel packages of gstreamer. Try installing these packages:

sudo apt-get install libgstreamer-plugins-base1.0-dev
share|improve this answer
    
I just edited the version on your answer to match my error. It works with the 1.0-dev package –  user1128171 Mar 2 '13 at 14:52
    
I had the same problem with Berasero v3.8 and this soled the problem. –  M6299 Oct 17 '13 at 18:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.