Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm pretty bad with Linux, but I've been using it for five years now, because there's some incredible free software and Open Source is good and all that stuff, and if I ever ran into a problem I could find a solution on these forums and mend it myself and learn a little along the way. However...

My Problem:

I've been trying a lot of fixes to get my graphics card working on the new netbook I bought. Sadly, I've been trying for the past few days and I'm pretty stumped. It would be particularly nice to get this working since my screen brightness can't be changed, and obviously having a netbook that drains battery doesn't make it worthwhile.

If I install the proprietary drivers recommended it will prevent booting.

Maybe there's no drivers for Ubuntu yet, and I should wait patiently.

Here are some people having the same problem:

http://ubuntuforums.org/showthread.php?t=2101078

My System:

  • Model: Aspire One, AO725-0826

  • OS: Ubuntu 12.04 64-bit

  • Processor: AMD C-70 APU with Radeon(tm) HD Graphics × 2

  • Video Card: Wrestler [Radeon HD 7290]

share|improve this question
    
I have the same card but Ubuntu 12.10 and everything works... Sort of... Have you tried Catalyst drivers? I have beene trying Catalyst 12.10 I think, right now version 13 is out: support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx –  Melon Mar 2 '13 at 8:27
    
Thanks for replying, Melon! Mostly I've been trying to install the Catalyst drivers, but no luck. I've downloaded the 13.1 .run file, and in terminal I get into the installation, but it is eventually cancelled because my "card is not supported." I have been able to install what I think is the same driver (ATI/AMD proprietary FGLRX graphics driver) through the 'Additional Drivers' in the 'System Settings' menu. But, it does not boot back into my desktop. Exactly like this issue, but I haven't followed it because my hardware is different. –  NicBaird Mar 2 '13 at 22:09
1  
This might be the problem: bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/… –  NicBaird Mar 2 '13 at 22:33
    
Have you tried playing HD movies? Do they work? Or did you play any OpenGL games? –  Melon Mar 3 '13 at 14:36
    
It couldn't properly play standard video files movies with gnome or VLC. I've decided that most likely there has not been adequate Ubuntu support for the new hardware yet, so I'm sending it back to restore it to its native Windows 8. I do have my trusty Lubuntu laptop though, which is as reliable, functional, and speedy as ever, so I'll make do for now. Maybe it's not so bad to have a Windows system handy for compatibility issues. Thanks for troubleshooting with me though! –  NicBaird Mar 9 '13 at 5:05

3 Answers 3

There is a kernel boot parameter tweak you can try for getting the backlight brightness to be adjustable. To see if the tweak will work without making any changes try:

echo 2000 | sudo tee /sys/class/backlight/intel_backlight/brightness

In terminal, if the brightness changes then the tweak will work.

To use the function keys to change it: Run this in a terminal:

sudo gedit /etc/default/grub

and change this line:

GRUB_CMDLINE_LINUX="quiet splash"

to:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

Save the file and run:

sudo update-grub

Now reboot. Your function keys for brightness should now work. Worked for me : )

share|improve this answer

Okay, two things:

  1. Try Ubuntu 13.04. The support seems to be a lot better from my experience. Brightness can be adjusted and battery life is acceptable.

  2. Try the Catalyst 13.3 beta drivers if the oepn source ones aren't up to your standards.

share|improve this answer

My System:

    Model: Foxconn AT-5570 (nettop)
    OS: Ubuntu 12.04 64-bit
    Processor: AMD C-70 APU with Radeon(tm) HD Graphics
    Video Card: Wrestler [Radeon HD 7290]

My Problem:

fglrxinfo - show incorrect information about my video card, driver (from official AMD site) is installed, but really not working, video acceleration too not working, windows in gnome environment have lags.

My Solution: When i install new core lts trusty:

sudo apt-get install --install-recommends linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty, and later I compile & install fresh drivers AMD, I did not pay attention (really driver install not correctly), when I noticed that something is wrong. I trying install different drivers with different methods. But i can`t resolving incorrect works video drivers.

Problem exist in xserver-xorg-video-ati-lts-trusty and xserver-xorg-dev. Official AMD drivers installer download and install xserver-xorg-dev and this make conflict.

How I find solution:

  1. I Remove official AMD driver sudo apt-get purge fglrx* and sudo apt-get autoremove
  2. sudo apt-get install --install-recommends xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty.

    I just re-install again a standard Ubuntu AMD (ATI xserver-xorg-video-ati-lts- trusty) drivers.

  3. After reboot I see, that video works perfectly without official AMD drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.