Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Lubuntu on my Aspire One 725. It has a Radeon 7290 HD. I already tryied to install the drivers but after rebooting, i can only log in via terminal, there's no graphic interface anymore.

I fixed it by uninstalling fgrlx.

So my question is: Is there a proper way to install the ati drivers on my netbook, without getting the login black screen? Thank you in advance!

share|improve this question

which driver have you tried to install? catalyst or catalyst-legacy? I think your card needs the catalyst-legacy driver which currently does not support xorg 1.13! To find out which version of Xorg your using, open a terminal window and type Xorg -version. If you have xorg 1.13 you can try downgrade to xorg 1.12 or wait until AMD updates the catalyst-legacy driver to support xorg 1.13.

But anyway why do you need the driver? Afaik lubuntu doesn´t need 3-D support, the opensource-driver should work well...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.