Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Toshiba laptop, Ubuntu does seem to be able to hard blocking/unblocking the wifi card.

I dual-boot with Windows 7 and usually I leave wifi on. However, yesterday I disabled wifi while using Windows and when I rebooted into Ubuntu, I couldn't unblock the wifi. I had to reboot into Windows to re-enable the wifi.

rfkill unblock all and rfkill block all do not work for the hardware switch. Fn + F8 toggles the soft block of the wifi, whereas on Windows it toggles the hardware switch.

This is the result of lspci | Network

04:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Is there a way to enable Ubuntu to hard block/unblock the wifi card?

share|improve this question

1 Answer 1

It is a bug in udev

Hummm, Suspend -> resume for me it works

It also cured the fact my altgr key was not functioning

My guess is event listener is stacking events and there is a lock preventing the queue from depiling the events. Suspend -> resume seems to «unfreeze» the queue...

I had a lot of problems related to this one... I guess taking the action (like rfkill unblock all) might be necessary too...

share|improve this answer
1  
Could you add a link to the bug? –  Braiam Sep 2 '13 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.