Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I hope someone can help me because I just dont know what else to do! I have a Dell XPS 15z that has 1TB HDD and 128GB SSD. It came with Windows 8 installed on the SSD. First thing I did was install ubuntu 12.10 on the SSD but the installer couldnt find Windows 8 so for like a month my computer would just boot into Ubuntu. I had no problems since, at the moment, I am not using Windows (but i would want to have it someday).

So everything was ok until today that I run a software update on Ubuntu and after the restart my computer just went into Windows 8 and I now cant go back into Ubuntu.

Any suggestions? Thanks

EDIT:

I was just able to enter Ubuntu by pressing F12 at turn on and going into boot options. I could see both, Windows 8 and Ubuntu(and Ubuntu's swap I think). MAy be from ubuntu I could fix this easier?

Then i went and downloaded the boot repair app: boot repair check http://paste.ubuntu.com/5577728/

And then I trusted the boot repair app and after the supposed "fix" it gave me this report http://paste.ubuntu.com/5577739/ and after the restart I get this:

after the restart I get messages like

screenshot at startup

failed to open /efi/Microsoft/boot/grubx64

failed to load grub

failed to open /efi/boot/grubx64.efi

failed to load grub

checking media [media]

checking media

And then after a few seconds it goes into a grub menu in which only the Ubuntu option works. The others fail.

screenshot grub menu

THANKS! hope someone can help me!

share|improve this question
    
Are you saying that Grub doesn't load? –  oaskamay Mar 1 '13 at 22:39
    
Grub never did. When I installed Ubuntu for the first time, it couldnt find Windows 8 and because of that I guess it just figured I didnt need grub for just one OS. –  fersarr Mar 1 '13 at 22:48
    
When you install Ubuntu via USB/DVD/CD, Grub should automatically install itself onto the MBR. Did you install with Wubi (i.e. in-Windows installation)? –  oaskamay Mar 1 '13 at 22:50
    
No i didnt use wubi. When I installed Ubuntu, Windows disappeared until I did the ubuntu software update. I just ran a boot repair check, heres the link paste.ubuntu.com/5577728 –  fersarr Mar 1 '13 at 22:52

1 Answer 1

up vote 1 down vote accepted

GRUB was loading on your computer; it just wasn't presenting a menu because it believed there were no options available. As I understand it, you're now back to something that's virtually identical to your original state -- you can boot Linux but not Windows. The only difference is that now you've got a GRUB boot menu. If I've misunderstood, please clarify.

Unfortunately, booting Windows is not GRUB's strong point. There are numerous suggested GRUB configurations available online, but they often fail -- what works on one system fails on another. The one I've got offhand is this:

menuentry "Windows 8" {
    insmod part_gpt
    insmod chain
    set root='(hd0,gpt1)'
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

You'd need to enter this into /etc/grub.d/40_custom and then run sudo update-grub to make it available. Note that you may need to change the set root= line and/or the chainloader line for your boot loader. Because you've run Boot Repair, the chainloader line needs to reference the Windows boot loader's new filename (probably bkpbootmgfw.efi).

Another option is to install my rEFInd boot manager, which tends to be more reliable at launching Windows. Unfortunately, the fact that you've run Boot Repair complicates this, because Boot Repair moves and renames the Windows boot loader and copies GRUB into the old Windows boot loader location. Thus, you may need to change this back, either manually or by re-running Boot Repair and selecting options to undo its changes.

With either solution, you may need to either disable Secure Boot in your firmware or install an updated version of shim. The former is likely to be much easier, but I can't say precisely how to do it because it varies from one EFI to another. The latter option is trickier and is complex. See the rEFInd shim documentation for details on how to do it with rEFInd.

share|improve this answer
    
thanks, I am seeing that most people disabled secure boot. Anyways, I am now able to boot Windows or linux but by using F12 (bOOT OPTIONS) at startup. –  fersarr Mar 4 '13 at 2:51
    
It's probably not Secure boot, but Intel smart response that is problematic. see help.ubuntu.com/community/UEFI –  NoBugs Nov 23 '13 at 18:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.