Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I successfully installed Openbox on my laptop running Kubuntu 12.04 but when I login using the kde/openbox session, the desktop icons of kde, show me an "open with ?" pop up, while the kmenu is almost empty and isn't showing any application entries (only leave, command, or favorites).

I couldn't find a way until now to establish a correct behaving of kde/openbox, so I would like to know where to find the method for configuring this.

share|improve this question
add comment

1 Answer 1

Testing

Installing the openbox.

Making a new user.

Log in as the new user.

enter image description here

The KDE Menu is empty.

enter image description here

Trying to fix

Running the kbuildsycoca4 to rebuild the system configuration cache.

:~$ kbuildsycoca4 --help
Usage: kbuildsycoca4 [Qt-options] [KDE-options] [options] 

Rebuilds the system configuration cache.

Generic options:
  --help                    Show help about options
  --help-qt                 Show Qt specific options
  --help-kde                Show KDE specific options
  --help-all                Show all options
  --author                  Show author information
  -v, --version             Show version information
  --license                 Show license information
  --                        End of options

Options:
  --nosignal                Do not signal applications to update
  --noincremental           Disable incremental update, re-read everything
  --checkstamps             Check file timestamps
  --nocheckfiles            Disable checking files (dangerous)
  --global                  Create global database
  --menutest                Perform menu generation test run only
  --track <menu-id>         Track menu id for debug purposes

There is an error - missing files.

enter image description here

Starting the Dolphin file manager with the root rights (kdesudo dolphin).

Browsing to the /etc/xdg/menus/. There is the kde4-applications.menu but not the applications.menu.

Making a softlink / symlink from the applications.menu to the kde4-applications.menu (KDE drag&drop menu "link here").

enter image description here

enter image description here

Running the command:

kbuildsycoca4 --noincremental

again...

The KDE menu is now populated with the available applications.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.