Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want play a Blu Ray Video from my hard drive with Boxee, but it chokes all the time. I've tried to play it with others video players but it is the same.

I think that is a 10gb .mkv file with 10Gb. Stuttering video with VLC , mplayer, and the default video player on ubuntu.

I read in many Forums just can´t put this to work. Any idea? thanks.

Ubuntu 10.10,

  • My PC specs:
  • Single Core 2Ghz
  • ATI HD 4350 (i have installed the drivers from "Hardware Drivers"),
  • 2G Memory

*EDIT: Problem solved, this weekend had buy a motherboard and a processor DualCore 2.5Ghz, no more stuttering. thanks alot for your help.

share|improve this question
    
Can you please explain two things a little better: 1. What's the input? Are we talking about a Blu Ray that has been decrypted to disk or just a high-definition video (that's been created from a Blu Ray source)? 2. Define "choke". Stuttering video? Not playing at all? –  Oli Feb 14 '11 at 11:38
    
Thanks for reply and sorry about my english. 1. A high definition video, i think that is a .mkv file with 10Gb. 2. yes, Stuttering video that stuttering on VLC , mplayer, default video player on ubuntu... –  hugocreal Feb 14 '11 at 11:58
    
Please add information to your question, not in the comments, they just get lost down here. –  Jorge Castro Feb 14 '11 at 16:09
    
hello everyone, First of all, thanks for try help me. I think that have find problem, my PC with ubuntu is connected to a KVM and 20" Monitor that have 3 PCs, yesterday i connect the pc to my TV 42" from HDMI cable, this TV have 100hz of frequency, the movie in Blu Ray run just fine, the problem return when i come back to KVM, and a fused light goes on in my brain, i going to see the frequency of ubuntu connectet VGA to KVM and i see "45hz" my 20" Monitor is 75hz. Out of KVM all goes right. One more time thanks for your help and sorry about my awesome english. –  hugocreal Feb 16 '11 at 8:49

6 Answers 6

up vote 1 down vote accepted

Try it on any other operating system with this specs and it will choke. Some Single Core 2 Ghz can't handle even 720p but 1080p it's a sure...

I have a PC: Athlon 3000+, Single Core 2 Ghz, ATI Radeon 4850 HD(1GB ; 512 bit) with big bandwidth and it chokes too... Overclocked to 2.4 Ghz and anyway chokes for 1080p(Blu-Ray).

Btw, try to compile the new kernel(2.6.38-rc4) it gives awesome performance boost(I don't know if it gives the boost for Single Core, for Multi-Core for sure but anyway, u may wanna try): https://wiki.ubuntu.com/KernelTeam/GitKernelBuild .If u want to compile the Kernel, don't forget that u need at least 7GB disk space.

share|improve this answer
    
Thanks for your help. I Going to try it and later post the result. –  hugocreal Feb 14 '11 at 12:56

My guess is the video is stuttering because it's trying to decode it entirely on the CPU. Even a fairly beefy CPU will have to work very hard to play a full 1080p video stream. GPU-accelerated video playback is much less taxing.

I have an Nvidia card using VDPAU with the proprietary driver, so I'm not sure what options there are for hardware accelerated video on ATI cards. First thing you should do is confirm your video hardware is even capable of video playback acceleration... models older than 2 years may not. Second, make sure you're using a driver that supports it - it's possible the ATI open source driver supports it even if the (better performing?) proprietary one doesn't. Lastly, you'll need a build of your media player software that is confirmed to make use of the appropriate video acceleration API - I recall that the mplayer in the repos for releases of Ubuntu before 10.10 didn't have VDPAU support, and it was a pain to track down which features that binary actually supported.

I googled "ati linux hardware accelerated video" (minus the quotes) and came across a few things, but nothing conclusive. Maybe an ATI user can chime in here with some help.

I would suggest editing the title of your question to be more descriptive, something like "Slow Blu Ray video playback on Boxee hardware".

share|improve this answer

You might want to try using the open source driver instead of the proprietary ATI "Hardware Driver". In my experience the open source driver does a MUCH better job playing videos and the proprietary ATI driver can not even play DVDs smoothly.

share|improve this answer
    
I just downloaded the .run file from ATI Web Site, is this? can you give me some lights? thank you –  hugocreal Feb 14 '11 at 14:04

I solved the problem using XBMC instead of VLC. I really can't tell you why this works, but with vlc the hd-videos stuck all the time, XBMC seems to work much faster.

share|improve this answer
    
I have had better luck with XBMC as well just in general... –  TheX Feb 16 '11 at 15:13

Install sudo apt-get install xvba-va-driver libva-glx1 libva-x11-1 vainfo and command vainfo should give you

libva: libva version 0.32.0 Xlib: extension "XFree86-DRI" missing on display ":0.0". libva: va_getDriverName() returns 0 libva: Trying to open /usr/lib/dri/fglrx_drv_video.so libva: va_openDriver() returns 0 vainfo: VA API version: 0.32 vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8 vainfo: Supported profile and entrypoints VAProfileH264High : VAEntrypointVLD VAProfileVC1Advanced : VAEntrypointVLD

Open up vlc and enable GPU acceleration under inputs and codecs.

share|improve this answer

For VLC see some of the optimisations here, focused on Nvidia but should help for ATi too. VLC's HD GPU-based decoding I believe is still a little experimental.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.