Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install Dovecot on Ubuntu 12.04 LTS, and it recommends that we place the control files into a partition which will not be limited by the filesystem quota.

If I create an ext4 partition with 2 gigs, how do I remove the quota on that partition? I know the partitions are defined in /etc/fstab, and I think usrquota and grpquota have to be explicitly set to disabled.

But I am unsure what the entire line should look like.

Is it something like:

/dev/hda2       /       ext4    defaults,usrquota,grpquota        1       0        0

On the other hand, I found something called quotaon and quotaoff. Would this be used instead of fstab? Is there a difference?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Your mount points are defined in /etc/fstab and those options will be used by default every time you boot.

So if you use the line:

 /dev/hda2       /       ext4    defaults,usrquota,grpquota        1       0        0

quotas will be enabled when you boot.

The commands quotaon and quotaoff will enable / disable quotas from the command line.

See: http://manpages.ubuntu.com/manpages/dapper/man8/quotaon.8.html for additional options.

So if you wish to disable quotas by default, use noquota in fstab

/dev/hda2       /       ext4    defaults,noquota        1       0        0
share|improve this answer
    
Could you clarify something for me. The fourth column in /etc/fstab represents mount options. There are two different types: FILESYSTEM INDEPENDENT/DEPENDENT SPECIFIC MOUNT OPTIONS. quotaoff is not an option in either of those. But I do see grpquota|noquota|quota|usrquota in the DEPENDENT option, however it also says this: These options are accepted but ignored. –  tabx Mar 1 '13 at 19:50
    
I found the description of mount options here: linux.die.net/man/8/mount –  tabx Mar 1 '13 at 19:51
    
Read the entire line, lol - "These options are accepted but ignored. (However, quota utilities may react to such strings in /etc/fstab.) " So mount will ignore these strings, but quota uses them. –  bodhi.zazen Mar 1 '13 at 19:54
    
Whoops, why did I miss that. Thank you, I think I understand it. –  tabx Mar 1 '13 at 19:55
    
I guess as a curiosity question: does using quotaon/quotaoff just modify /etc/fstab to use noquota? What would be the benefit of using this command rather than manually specifying it in /etc/fstab? –  tabx Mar 1 '13 at 19:58

Quotas are off by default, and must be explicitly enabled by building quota files with quotacheck, and placing the quota flags in /etc/fstab for quotaon -a to recognize and activate the quotas during boot.

So unless you did all that, you don't have to do a thing.

If you did, then you can turn them off with quotaoff and removing the flags from /etc/fstab to prevent them from being turned back on at the next boot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.