Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having serious problems with my computer right now. Any help would be GREATLY appreciated! Here is the story :)

Looking for speed I decided to install Ubuntu 10.04 LTS about two months ago. It was working great for a month. Absolutely no problems. It was fast while using and it booted up and shut down incredibly fast too. After realizing some PPAs just dont support 10.04 anymore and wont ever again, I decided to upgrade to 12.04 LTS. Everything went smooth. Upgrade was fine. Then I noticed boot problems a few days later. Lots of error messages. Sometimes the hard drive would "decide" on its own to go into read only mode while I was using the computer throughout the day. I couldnt save files any longer, I couldnt save open tabs in browsers, I couldnt copy files, I could not open programs, etc. In short, the computer or the hard drive went "read only" on me. I noticed more problems on boot. For example, sometimes It would just never boot up. It might go to a grub> prompt or not even get that far.

One of the errors I always see on boot is this... an ata4 error message...

ata4.00: error: { ICRC ABRT }

This became crippling for me. I could no longer get things done if I could get the computer to boot up at all.

Originally wanting Ubuntu 10.04 for its speed and stability, I played around with a few other OSes like Xubuntu, Lubuntu & Mint, but settled on the new Elementary OS Luna still in beta. Install went great. Used it for a couple days, then the dreaded read only hard drive problem started up again. Now I can barely boot up into my system. (Im using it now and trying to type fast in case it goes into read only mode!). Here is a reoccurring error grouping that happens on just about every boot. Essentially I see if the computer can get passed the errors it will boot, if it cant it goes to grub or locks up.

In short:

  • 10.04 worked flawlessly
  • 12.04 had all sorts of problems
  • Elementary OS Luna (newest beta) same problems

Not sure where to go from here on this. Ive read so many forums and pages and comments about this type of error message. From changing the hard drive cable, to changing the hard drive, to running all sorts of terminal commands.

Any ideas would be so helpful. Thank you so much!

PS... if I cant figure this out, Im considering re-installing Ubuntu 10.04 and see if it runs stable again. That would be very interesting indeed.

PPS... Disk Utility shows SMART Status of my hard drive as HEALTHY

share|improve this question

First of all,I have to tell you that 12.10 is NOT worse than 10.04, but the update thing is the problem. Second I had some sort of same problem, although I could solve it for myself, but it worked that terrible that I had to re install it at last. In your case I don't think there is any problem with your hard disk, but I'm afraid I have to tell you that the best way is to reinstall 12.10.

share|improve this answer
I agree that the update is not as ideal as a fresh install. But somehow the problem remains as Ive wiped the drive with parted magic and did a fresh install, this time with elementary OS. all things said & done, im running a fresh system now and still having the problems. – I Heart Ubuntu Mar 1 '13 at 18:34
Did you format your partition before fresh install? Then it might be your partition table problem. This can be fixed, but loss of data is possoble – Mostafa Shahverdy Mar 1 '13 at 18:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.