Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I went to the download-page downloaded the fs2_open_3.6.16.tar.bz2 package, extract it. runned it like so ./fs2_open_3.6.16 but i get the below error:

./fs2_open_3.6.16: error while loading shared libraries: cannot open shared object file: No such file or directory

(The liblua5.1-0 package is installed)

I tried

ln -s ./

But it didn't work, same error.

Question: How do i fix this error and play the game

Note: I am using Ubuntu 12.10

The output of: ldd ./fs2_open_3.6.16 =>  (0x00007fffa22cc000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0566c3e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0566a11000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0566808000) => /usr/lib/x86_64-linux-gnu/ (0x00007f05665b7000) => /usr/lib/x86_64-linux-gnu/ (0x00007f05663b0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0566156000) => /usr/lib/nvidia-current-updates/ (0x00007f0565e39000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0565bba000) => /lib/x86_64-linux-gnu/ (0x00007f0565993000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0565766000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0565541000) => /usr/lib/x86_64-linux-gnu/ (0x00007f056523d000) => /lib/x86_64-linux-gnu/ (0x00007f0564f41000) => /lib/x86_64-linux-gnu/ (0x00007f0564d2b000) => /lib/x86_64-linux-gnu/ (0x00007f056496b000) => /lib/x86_64-linux-gnu/ (0x00007f056474e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0564464000) => /lib/x86_64-linux-gnu/ (0x00007f056425f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f056405b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0563e13000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0563ad8000) => /usr/lib/x86_64-linux-gnu/ (0x00007f05638c6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f05635f9000) => /lib/x86_64-linux-gnu/ (0x00007f05633f0000) => /usr/lib/nvidia-current-updates/tls/ (0x00007f05631ed000) => /usr/lib/nvidia-current-updates/ (0x00007f0560e03000) => /lib/x86_64-linux-gnu/ (0x00007f0560beb000)
/lib64/ (0x00007f0566f05000) => /usr/lib/x86_64-linux-gnu/pulseaudio/ (0x00007f056098e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0560784000) => /lib/x86_64-linux-gnu/ (0x00007f0560540000) => /usr/lib/x86_64-linux-gnu/ (0x00007f0560322000) => /lib/x86_64-linux-gnu/ (0x00007f055ff91000) => /lib/x86_64-linux-gnu/ (0x00007f055fd64000) => /lib/x86_64-linux-gnu/ (0x00007f055fb3c000) => /lib/x86_64-linux-gnu/ (0x00007f055f931000) => /usr/lib/x86_64-linux-gnu/ (0x00007f055f6cb000) => /usr/lib/x86_64-linux-gnu/ (0x00007f055f4c5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f055f2c0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f055f0ba000) => /lib/x86_64-linux-gnu/ (0x00007f055eea0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f055ec53000) => /usr/lib/x86_64-linux-gnu/ (0x00007f055e784000) => /lib/x86_64-linux-gnu/ (0x00007f055e568000)

I downloaded fs2open3616_1.0-1_amd64.deb insalled it with the software-center, and I also installed the missing lib files(i386) which it needed according to the ldd ./fs2_open_3.6.16 command, like so sudo apt-get install liblua5.1-0:1386 (After installing the i386 lib I updated the output of ldd ./fs2_open_3.6.16)

here is the error:

ERROR: " Web cursor bitmap not found. This is most likely due to one of three reasons: 1) You're running FreeSpace Open from somewhere other than your FreeSpace 2 folder;

2) You've somehow corrupted your FreeSpace 2 installation, e.g. by modifying or removing the retail VP files;

3) You haven't installed FreeSpace 2 at all. (Note that installing FreeSpace Open does NOT remove the need for a FreeSpace 2 installation.)

Number 1 can be fixed by simply moving the FreeSpace Open executable file to the FreeSpace 2 folder. Numbers 2 and 3 can be fixed by installing or reinstalling FreeSpace 2." at graphics/2d.cpp:645

share|improve this question
The file names in the symlink might not be quite right; to get the names and location, try dpkg -L liblua5.1-0. That will reveal the exact location of the files. I don't get the error on a 32bit system, so perhaps you need to state the location of the liblua file explicitly with LD_LIBRARY_PATH. You could set that in a wrapper script that launched the game. – user76204 Mar 2 '13 at 0:45
@Mik, How do i do that!? – blade19899 Mar 3 '13 at 23:41
You could do it in a similar way to how I did it in the script for this answer. You could also try one of the 64 bit builds from this location; there isn't one for 12.10 yet, but the 12.04 one might work or could be tweaked to install. – user76204 Mar 4 '13 at 17:39
@Mik I edited the answer with. and gave the output of ldd ./fs2_open_3.6.16 i found out that i didn't had installed the I386 lib what this game needed i installed like so sudo apt-get install liblua5.1-0:1386 but no when runned i get another error. read the answer for the error. – blade19899 Mar 5 '13 at 15:55


There can be a number of complications when setting up FreeSpace 2 Open (FS2Open) on an Ubuntu system. The original retail Freespace 2 game data is still needed, as the FS2Open files in part provide a way of playing the game on modern Linux based (and other) systems. As the official game forums is the place to go for a more general guide on running the game, I will concentrate on addressing how to compile the launcher and then how to start the game on Ubuntu.

A compiled binary of FS2Open (but not the launcher) is hosted at the official site and also here, though these links will change for later versions.

Initial Problems

1) We have already partly solved some problems in the comments:

  • If you have problems with shared libraries, run ldd ./name_of_fs2_binary to see if everything is being found. If not, and if you are on a 64 bit system, you may need to install the i386 version of the package, with, for example,

    sudo apt-get install liblua5.1-0:i386
  • The first run of the FS2Open binary (whether errors are encountered or not) will create ~/.fs2_open/fs2_open.ini, where important graphics settings will be stored, and can be edited manually or set with the wxlauncher (see below). They must be set properly by one or the other method however.

Main Problem

However, to solve the final issues with the game not starting up, it is probably easiest to compile and use wxlauncher, rather than manually creating a startup script.

If the launcher is to work after compiling and installing, you must have:

  • installed the original Freespace 2 data files from your retail copy of the game correctly and ensured that the permissions are correct. For more information, see the official game forums. It is important to say that all files must be lowercase or the game will not find them and you will get errors.
  • moved the downloaded FreeSpace 2 Open binary to the top level of the game folder (/home/$USER/games/FreeSpace2 for example).
  • installed openal; however, if you decide to configure the game setup manually and not use the launcher, you will still need to install openal with

    sudo apt-get install libopenal1

Compilation and Installation

Now, to the compilation and installation of the launcher. Download the appropriate source code package from the official site and check the sha1 signature with sha1sum.

As usual, quite a few dependencies are necessary. The usual packages can be installed with:

sudo apt-get install cmake build-essential checkinstall

The specific packages that are necessary can be installed with:

sudo apt-get install python python-dev python-markdown libwxgtk2.8-dev libwxbase2.8-dev libopenal1 libopenal-dev wx2.8-headers wx-common wx2.8-examples wx2.8-i18n libsdl1.2-dev libsdl1.2debian

These are the package names on 12.04, but they should be the same for 12.10. The readme included with the download notes that the version of wxWidgets should be 2.8.10+, but not 2.9.x.

Using terminal, cd to your download folder and run

tar -xzvf wxLauncher-0.9.1.tar.gz

Now, cd to wxLauncher-0.9.1 and, because this is a cmake build, we usually now create a build folder and move to that:

mkdir build && cd build

Next configure the build with

cmake .. -DUSE_OPENAL=1

(For a debug build add, -DCMAKE_BUILD_TYPE=Debug)

I found that another compile flag specified in the readme included with the download wasn't necessary, as when the program was installed with checkinstall and then run, that particular error did not occur and all the launcher's files were being found correctly.

Now, run make to compile the program, and then from the same directory (build), run

sudo checkinstall --pkgname=wxlauncher --provides=wxlauncher

and keep pressing return to accept the other defaults.

Now type wxlauncher and you will be able to specify the path of your FreeSpace 2 main folder with the game data and with the downloaded FS2Open binary. You can also set your options and launch the game (screenshots below):

enter image description here

Make sure that you select the correct freespace 2 folder; the options will appear when the binary is detected. Click refresh and click the box again if it isn't detected.

enter image description here

share|improve this answer
I have bin trying for a while now but i still get this error, As is shown in my question(ERROR: Web cursor bitmap not found. This is most likely due to one of three reasons: 1) You're running FreeSpace Open from somewhere other than your FreeSpace 2 folder; .......) – blade19899 Mar 18 '13 at 20:21
I'm not sure how we should proceed, as everything loaded on my 32 bit system. Did you place the fs2open binary in the game data folder and follow the steps under the 'main problems' heading of my answer? If it isn't an issue to do with installing the game data, it could be a 64 bit issue. There may be some information on the official Freespace Open forums, and it may be worth asking there as well. – user76204 Mar 18 '13 at 20:41
One other possibility: you could compile the main fs2open binary against the libraries on your system and see if it then loads. That does sometimes fix problems; the source code is available here. Download, check the md5, extract, cd to folder, run ./ && make. The dependencies are openal, sdl, theora, vorbis, ogg development libs. – user76204 Mar 18 '13 at 20:49

I solved this problem by installing the lua.i386 package. Then, I made a link to in /usr/lib, named

sudo apt-get install liblua5.1-0:i386

Then, run

sudo ln -s /usr/lib/ /usr/lib/
share|improve this answer
The OP said he installed liblua5.1-0:i386 and tried a symlink, but I think he said that was unsuccessful. – user76204 Apr 15 '13 at 16:15
@Mik that is correct! – blade19899 Apr 15 '13 at 16:26

Thanks for the procedure - worked great for me. I had one other problem with the libjansson4 package - the launcher started up just fine, but when I ran FS2, I got "package not found errors."

I had to run "sudo apt-get install libjansson4:i386" to resolve the problem.

I also wanted to add that I was having trouble building the GTK yal launcher. After installing the packages recommended for building wxlauncher, it built fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.