Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed ubuntu 12.04. i heard that ethernet interface automatically get a link local address but in my ubuntu box it's not getting link local address.

Command

ifconfig -a 

output

Link encap:Ethernet  HWaddr 00:1b:38:a1:a2:50  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:19 

when i trying to assign it manually using command

ifconfig eth0 inet6 add fe80::21b:38FF:FEa1:a250/64

it assigned to interface eth0. but when i try to ping it using

ping6 -I eth0 fe80::21b:38FF:FEa1:a250

it gives

connect:cannot assign requested address ping6 ubuntu

command

ip -6 route get fe80::21b:38FF:FEa1:a250

gives

fe80::21b:38ff:fea1:a250 from :: via fe80::21b:38ff:fea1:a250 dev eth0  metric 0 
cache 

this may have some clue for someone.

share|improve this question
    
tried solution, add lines in /etc/network/interfaces [auto etho] and iface eth0 inet6 auto –  Sumit Kamboj Mar 1 '13 at 6:25
    
Please provide additional information by editing your question and not in a comment. That way the relevant parts are easier to find. –  guntbert Mar 1 '13 at 20:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.