Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How does one permanently turn off any and all system "recording" of used apps, directories, or files in Ubuntu 12.10?

I specifically DO NOT want a list of my recently used files showing up in my menu for anyone who may be looking over my shoulder to see. I have tried turning off everything in the "privacy app", and I have also told the app NOT to record activity from specific directories, files, and applications and I still see that my system is recording recently used files.

Any help on how to permanently turn off the recently used file list would be very appreciated. I do not merely want to prevent the recently used files from being displayed in the menu, I also want to make sure the system is not keeping any record of recently used files, directories, or applications anywhere on the system. I would like to be able to do this from the privacy app, as that's what it implies it's supposed to do anyway, but obviously doesn't.

share|improve this question
    
Please clarify if you are referring to the Unity dash or the individual application's open and save dialog options. –  jokerdino Mar 1 '13 at 6:17
    
Sorry, I do not understand this question. I am not using Unity... I am using several other DEs they all have the same problem in that the recently used files keep showing up no matter how I configure the settings in the privacy app... I am assuming that the privacy app is independent of whatever DE I am using. –  Jason Mar 2 '13 at 13:57
    
The privacy settings is specific to the recent files showing in Unity dash. If your issue is files showing in the recently used files, then it is a duplicate of Is there a way to completely remove “recently used” from open and save dialogs? –  jokerdino Mar 2 '13 at 14:11
    
    
OK... that article is for disabling the recent file logging for Nautilus... I am using Nemo... does that article apply to both of those apps? –  Jason Mar 2 '13 at 20:39

2 Answers 2

Go to System Settings > Privacy and select All from drop down menu in Forget Activity section and click on Delete history. If you turned off recording you wont see any more recent files.However Music and Video and Files lens will show your songs and videos collection from home directory. You can remove particular lens by

sudo apt-get purge unity-lens-video
share|improve this answer
    
us3r, sorry, but did you read my original post... I have already tried the settings in the privacy app and I am still seeing a list of my recently used files... I should NOT have to manually delete my history via a GUI app or via the CLI... I want to completely and permanently turn off any and all recently used file, directory, and application usage so that there is no record of any of it in the first place that I would have to go manually erase every time I open a file or a directory. –  Jason Mar 2 '13 at 13:54

This worked for me on manjaro cinnamon, disabled Recent Files

http://www.webupd8.org/2012/12/nautilus-36-how-to-clear-recent-files.html

To clear the Nautilus "Recent" files, you need to remove the "~/.local/share/recently-used.xbel" file - to do this from the command line, copy/paste the command below in a terminal:

rm ~/.local/share/recently-used.xbel

To permanently disable any recent files from showing up in the Nautilus Recent sidebar item, open the "~/.config/gtk-3.0/settings.ini" file with a text editor:

gedit ~/.config/gtk-3.0/settings.ini

and under "[Settings]", add the following lines:

gtk-recent-files-max-age=0
gtk-recent-files-limit=0

If this file does not exist, create it. Make sure the header says "[Settings]" and not "Settings". This is how the file should look after editing it:

[Settings]
gtk-recent-files-max-age=0
gtk-recent-files-limit=0

(there can be other items below these, of course).

To apply the changes, log out and log back in or follow the steps under "Clear the Nautilus Recent Files list" above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.